您的位置:首页 > 其它

【原】 POJ 1050 To the Max 求二维矩阵的最大子矩阵 解题报告

2010-11-04 21:17 555 查看
 

http://poj.org/problem?id=1050

方法:二维转一维
1、使用积累数组cumarr[1...n][1...n],使得求任意块儿子矩阵和的复杂度为O(1),cumarr[i][j]为cumarr[1...i][1...j]子矩阵的和,
   通过cumarr[i][j]=cumarr[i-1][j]+cumarr[i][j-1]-cumarr[i-1][j-1]计算积累数组,复杂度为O(N*N),
2、枚举+dp
   对矩阵的行枚举,确定矩阵区域的上下界imin和imax,此时就可以进行类似一维数组最大和的方法,每个枚举的矩阵区域负责度O(N)。
总复杂度为O(N*N)+(N*N)*O(N)=O(N^3)

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4

0 -2 -7 0 9 2 -6 2

-4 1 -4 1 -1

8 0 -2

Sample Output

15

 

[code][code] #include <stdio.h>


#include <iostream>


 


using namespace std ;


 


//只用1...n,以便和积累数组对应


int a[101][101];


int cumarr[101][101];


 


void run1050()


{


int n,val ;


int i,j ;


int imin,imax ;


int maxendinghere,maxsofar ;


int tmp ;




scanf( "%d", &n );


 


//积累数组边界值


for( i=0 ; i<=n ; ++i )


    {


    cumarr[0][i] = 0 ;


    cumarr[i][0] = 0 ;


}


 


//输入矩阵并求得积累数组


for( i=1 ; i<=n ; ++i )


    {


    for( j=1 ; j<=n ; ++j )


   {


   scanf( "%d", &(a[i][j]) ) ;


   cumarr[i][j] = cumarr[i-1][j] + cumarr[i][j-1] - cumarr[i-1][j-1] + a[i][j] ;


   }


}


 


//对矩阵的行枚举,确定矩阵区域的上下界imin和imax,


maxsofar = a[1][1] ;


for( imin=1 ; imin<=n ; ++imin )


    {


    for( imax=imin ; imax<= n ; ++imax )


   {


   //进行类似一维数组最大和的方法


   maxendinghere = cumarr[imax][1] - cumarr[imin-1][1] ;


   for( j = 2 ; j<=n ; ++j )


  {


  tmp = cumarr[imax][j] - cumarr[imin-1][j] - cumarr[imax][j-1] + cumarr[imin-1][j-1] ;


  maxendinghere = std::max( maxendinghere+tmp , tmp ) ;


  maxsofar = std::max( maxsofar , maxendinghere ) ;


  }


   }


}


 


printf( "%d\n", maxsofar ) ;


}

[/code]
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: