您的位置:首页 > 其它

poj2377解题报告

2010-08-25 14:25 267 查看
Bad Cowtractors

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6456Accepted: 2816
Description
Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
Output
* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
Sample Input
5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output
42

Hint
OUTPUT DETAILS:

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.
题目大意:求一最大生成树





思路:这个题让我快崩溃了,WA了很多次,最后看discuss说有重边。。。改完AC了 疯了。。。



#include<iostream>
using namespace std;
struct t
{
	int s,e,l;
}tree[2010],h;
int dis[2010][2010];
int main()
{
	int n,c,i,j,k,a,b,m;
	while(cin>>n>>c&&n)
	{
		int flag=1;
		memset(dis,0,sizeof(dis));
		for(i=1;i<=c;i++)
		{
			cin>>a>>b>>j;
			if(dis[a][b]<j)
			{	dis[a][b]=j;	dis[b][a]=j;	}
		}

		for(i=1;i<n;i++)
		{
			tree[i].s=1;
			tree[i].e=i+1;
			tree[i].l=dis[tree[i].s][tree[i].e];
		}
		for(i=1;i<n;i++)
		{
			int min=0;
			for(j=i;j<n;j++)
				if(tree[j].l>min)
				{
					min=tree[j].l;
					m=j;
				}
			if(min==0)
			{	flag=0;	break;	}
			else
			{
				h=tree[i];	tree[i]=tree[m];	tree[m]=h;
				for(j=i+1;j<n;j++)
					if(tree[j].l<dis[tree[i].e][tree[j].e])
					{
						tree[j].s=tree[i].e;
						tree[j].l=dis[tree[j].s][tree[j].e];
					}
			}
		}
		if(flag)
		{
			int s=0;
			for(i=1;i<n;i++)
				s+=tree[i].l;
			cout<<s<<endl;
		}
		else
			cout<<"-1"<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: