您的位置:首页 > 其它

3438 Look and Say

2010-08-08 10:37 441 查看
Look and Say

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 6174Accepted: 3731
Description
The look and say sequence is defined as follows. Start with any string of digits as the first element in the sequence. Each subsequent element is defined from the previous one by "verbally" describing the previous element. For example, the string 122344111 can be described as "one 1, two 2's, one 3, two 4's, three 1's". Therefore, the element that comes after 122344111 in the sequence is 1122132431. Similarly, the string 101 comes after 1111111111. Notice that it is generally not possible to uniquely identify the previous element of a particular element. For example, a string of 112213243 1's also yields 1122132431 as the next element.
Input
The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to 1000 digits.
Output
For each test case, print the string that follows the given string.
Sample Input
3
122344111
1111111111
12345

Sample Output
1122132431
101
1112131415

水题,秒杀之!

#include<iostream>
using namespace std;
char s[1008];
int main()
{
int T,i;
cin>>T;
while(T--)
{
cin>>s;
int len=strlen(s),count=1;
for(i=0;i<len;i++)
{
if(s[i]==s[i+1])
count++;
else
{
cout<<count<<s[i];
count=1;
}
}
cout<<endl;
}
return 0;
}
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: