您的位置:首页 > 其它

POJ1079 Red and Black(搜索)

2010-04-11 15:59 330 查看
Red and Black

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 10989Accepted: 5570
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13
进行搜索,没有什么特别要说明的。。。。。

#include<iostream>
using namespace std;

int W,H;
char Map[21][21];

int dfs(int x,int y)
{
if(x<0||x>=W||y<0||y>=H) return 0;
if (Map[x][y]=='#') return 0;
else
{
Map[x][y]='#';
return 1+dfs(x-1,y)+dfs(x+1,y)+dfs(x,y-1)+dfs(x,y+1);
}
}

int main()
{
int i,j;
while(cin>>H>>W && W!=0 && H!=0)
{
for (i=0;i<W;i++) cin>>Map[i];//read

for (i=0;i<W;i++)
{
for (j=0;j<H;j++)
{
if (Map[i][j]=='@') cout<<dfs(i,j)<<endl;
}
}
}
return 0;
}
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: