您的位置:首页 > 其它

浙大2008年复试上机题4

2008-07-04 19:28 246 查看
魔咒词典
Time Limit: 8000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 471 Accepted Submission(s): 121

Problem Description
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。
给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:
[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

Sample Input
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output
light the wand
accio
what?
what?

#include <iostream>
#include <string>
using namespace std;

const int BUK_SZ = 786433; // prime
int hcurse[BUK_SZ];
int hmean[BUK_SZ];

// see [Weiss05] P108
int my_hash( const char* key, int len )
{
	int h = 0, inc = len > 40 ? 2 : 1;
	for( int i = 0; i < len; i += inc )
		h = 37 * h + key[i];
	h %= BUK_SZ;
	if( h < 0 )
		h += BUK_SZ;
	return h;
}

struct node {
	char curse[20], mean[80];
	short lc, lm;

	void parse( char* line, int n )
	{
		++line;
		char *pc = curse, *pm = mean;
		while( *line != ']' )
			*pc++ = *line++;
		lc = pc - curse;
		line += 2;
		while( *line )
			*pm++ = *line++;
		lm = pm - mean;
		hcurse[hash_pos(hcurse,curse,lc)] = n;
		hmean[hash_pos(hmean,mean,lm)] = n;
	}

	int hash_pos( int* ph, const char* s, int len ) 
	{
		int h= my_hash( s, len );
		while( ph[h] != 0 )
			++h; // collide
		return h;
	}
} dict[100001];

int get_mean( const char* s, int len )
{
	int h = my_hash( s, len );
	while( hcurse[h] != 0 ) {
		if( dict[hcurse[h]].lc == len && memcmp( dict[hcurse[h]].curse, s, len ) == 0 )
			return hcurse[h];
		++h;
	}
	return 0;
}

int get_curse( const char* s, int len )
{
	int h = my_hash( s, len );
	while( hmean[h] != 0 ) {
		if( dict[hmean[h]].lm == len && memcmp( dict[hmean[h]].mean, s, len ) == 0 )
			return hmean[h];
		++h;
	}
	return 0;
}

int main( )
{
	char line[110];
	int n = 1;
	while( cin.getline(line,110),line[0]!='@' ){
		dict
.parse( line, n );
		++n;
	}

	for( (cin>>n).get(); n--; ) {
		cin.getline( line, 110 );
		if( line[0] == '[' ) {
			int p = get_mean( line+1, strlen(line)-2 );
			if( p == 0 )
				cout << "what?";
			else
				cout.write( dict[p].mean, dict[p].lm );
		}
		else {
			int p = get_curse( line, strlen(line) );
			if( p == 0 )
				cout << "what?";
			else
				cout.write( dict[p].curse, dict[p].lc );
		}
		cout << '/n';
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: