您的位置:首页 > 其它

The Hardest Problem Ever

2008-02-16 23:00 344 查看
FJNU.1604
PKU.1298

Description
Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping
himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so
incredibly sound, that no one could figure it out without knowing how it worked.
You are a sub captain of Caesar’s army. It is your job to decipher the messages sent by Caesar and provide
to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the
right to create the secure message (i.e., if the letter is ‘A’, the cipher text would be ‘F’). Since you are
creating plain text out of Caesar’s messages, you will do the opposite:
Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U
Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all
alphabetical characters will be upper case.

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be
formatted according to the following description, and there will be no blank lines separating data sets. All
characters will be uppercase.
A single data set has 3 components:
1. Start line ?C A single line, “START”
2. Cipher message ?C A single line containing from one to two hundred characters, inclusive,
comprising a single message from Caesar
3. End line ?C A single line, “END”
Following the final data set will be a single line, “ENDOFINPUT”.

Output
For each data set, there will be exactly one line of output. This is the original message by Caesar.

Sample Input
START
NS BFW, JAJSYX TK NRUTYFSHJ FWJ YMJ WJXZQT TK YWNANFQ HFZXJX
END
START
N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
END
START
IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
END
ENDOFINPUT

Sample Output
IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

Source
South Central USA 2002

My Program


#include<iostream>


#include<string.h>


#define N 200


using namespace std;




int main()




...{


char str
;


int i,n;




char plain[26]=...{'V','W','X','Y','Z','A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U'};


while(gets(str))




...{


if(!strcmp(str,"ENDOFINPUT"))


break;


if(!strcmp(str,"START"))


continue;


if(!strcmp(str,"END"))


continue;


n=strlen(str);


for(i=0;i<n;i++)


if((str[i]>='A')&&(str[i]<='Z'))


cout<<plain[(str[i]-'A')];


else


cout<<str[i];


cout<<endl;


}


return 0;


}

YOYO's Note:
直接替换掉大写字母输出就好……
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: