您的位置:首页 > 其它

Hello Kitty

2008-02-14 22:01 441 查看
FJNU.1945

Description
Kitty sends a kind of original email messages to her friend Garf. To write a message, she chooses a word W and a number n and replicates W n times horizontally. Then she repeats this string in the next line, but rotating the characters once to the left. And she repeats this 'rotate-and-output' process until the word W appears displayed as the first column of the rectangular pattern that she produces.
As an example, when she chooses the word Hello and the number 3, she gets the pattern:
HelloHelloHello
elloHelloHelloH
lloHelloHelloHe
loHelloHelloHel
oHelloHelloHell
Kitty has been sending such emails during the last three years. Recently, Garf told her that perhaps her work may be automatized with a software to produce Kitty's patterns. Could you help her?

Input
The input contains several test cases, each one of them in a separate line. Each test case has a word and a positive integer that should generate the corresponding rectangular pattern. The word is a string of alphabetic characters (a..z). The number is less than 10.
A line whose contents is a single period character means the end of the input (this last line is not to be processed).

Output
Output texts for each input case are presented in the same order that input is read. For each test case the answer must be a left aligned Kitty pattern corresponding to the input.

Sample Input
Love 1
Kitty 2
.

Sample Output
Love
oveL
veLo
eLov
KittyKitty
ittyKittyK
ttyKittyKi
tyKittyKit
yKittyKitt

Source
Colombian National Programming Contest 2006 Warmup

My Program


#include<iostream>


#include<string.h>


#define N 255


using namespace std;




int main()




...{


char str
;


int i,j,n,k;


while(cin>>str)




...{


if(!strcmp(str,"."))


break;


n=strlen(str);


cin>>k;


for(i=0;i<n;i++)




...{


for(j=i;j<n;j++)


cout<<str[j];


for(j=1;j<k;j++)


cout<<str;


for(j=0;j<i;j++)


cout<<str[j];


cout<<endl;


}


}


return 0;


}

YOYO's Note:
它有多组测试数据……
以前用C写了,大概是因为不会用!=EOF,一直搞不懂为什么WA……
现在无意间写了while的输入……它就AC了……很纠结……
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: