您的位置:首页 > 其它

HDOJ1002 A + B Problem II

2007-07-26 15:54 316 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7815 Accepted Submission(s): 1299


[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211


[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


[align=left]Author[/align]
Ignatius.L


#include <iostream>


#include <string>


using namespace std;


int main()




...{


int n;


cin>>n;


for(int i=1;i<=n;i++)




...{


string a,b,c;


cin>>a>>b;


int la=a.length()-1,lb=b.length()-1,jw=0,ta,tb,tt,f=0;


char tc;


while(la>=0||lb>=0)




...{




if(la<0) ta=0;


else ta=a[la]-'0';


if(lb<0) tb=0;


else tb=b[lb]-'0';


tt=jw+ta+tb;


jw=tt/10;


tc=tt%10+'0';


if(tc!='0') f=1;


c+=tc;


la--;lb--;


}


if(jw>0)




...{


f=1;


tc=jw+'0';


c+=tc;


}




if(i!=1)cout<<endl;


cout<<"Case "<<i<<":"<<endl;


cout<<a<<" + "<<b<<" = ";


if(f==1)




...{


for(int i=c.length()-1;i>=0;i--)


cout<<c[i];


cout<<endl;


}


else cout<<0<<endl;




}


return 0;


}

Download the code
http://dl2.csdn.net/down4/20070726/26155242796.cpp
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: