您的位置:首页 > 编程语言 > ASP

【Azure 应用服务】App Service 的.NET Version选择为.NET6,是否可以同时支持运行ASP.NET V4.8的应用呢?

2022-03-19 10:42 1001 查看 https://www.cnblogs.com/luligh

问题描述

App Service 的.NET Version选择为.NET6,是否可以同时支持运行ASP.NET V4.8的应用呢?

问题解答

答案是可以的,Azure App Service .NET可以同时支持多种.NET框架。因为在Azure App Service Window 环境中,已经安装了所有的版本SDK。

可以在Azure门户上的高级工具(Kudu:https://<yourappservicename>.scm.chinacloudsites.cn/)中的 Debug Console->CMD,  进入到D:\Program Files\dotnet\sdk目录 或者 D:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\ 目录,就可以查看到平台目前支持的版本号。

#查看 ASP.NET SDK版本文件
dir "D:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\"

#查看 .NET Core 版本信息
dir "C:\Program Files\dotnet\sdk"
#或者
dotnet --info

测试动画

PS: 如果要同时部署多个应用,需要通过 虚拟目录 把不同的应用分别部署到不同目录下即可。(参考以往博文:https://www.cnblogs.com/lulight/p/15778747.html

 

 

参考文档

显示受支持的 .NET Core 运行时版本:https://docs.azure.cn/zh-cn/app-service/configure-language-dotnetcore?pivots=platform-windows#show-supported-net-core-runtime-versions

显示受支持的 .NET Framework 运行时版本:https://docs.azure.cn/zh-cn/app-service/configure-language-dotnet-framework

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐