您的位置:首页 > 其它

优先队列+BFS训练(1)

2020-05-11 04:11 127 查看

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the
shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard
exactly once. He thinks that the most difficult part of the problem is determining the smallest number
of knight moves between two given squares and that, once you have accomplished this, finding the tour
would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the
”difficult” part.
Your job is to write a program that takes two squares a and b as input and then determines the
number of knight moves on a shortest route from a to b.
Input
The input file will contain one or more test cases. Each test case consists of one line containing two
squares separated by one space. A square is a string consisting of a letter (a…h) representing the column
and a digit (1…8) representing the row on the chessboard.
Output
For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’.
Sample Input
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6
Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
char a[5],b[5];
int book[100][100];
struct node
{
int x,y,step;
} q,p;
int flag,v;
int to[8][2]= {{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1}};
void bfs(int x,int y,int step)
{
queue<node>Q;
q.x=x;
q.y=y;
q.step=0;
book[q.x][q.y]=1;
Q.push(q);
while(!Q.empty())
{
q=Q.front();
Q.pop();
if(q.x==b[0]-'a'&&q.y==b[1]-'1')
{
flag=1;
v=q.step;
break;
}
int k;
for(k=0; k<8; k++)
{
p.x=q.x+to[k][0];
p.y=q.y+to[k][1];
if(p.x>=0&&p.y>=0&&p.x<8&&p.y<8&&book[p.x][p.y]==0)
{
book[p.x][p.y]=1;
p.step=q.step+1;
Q.push(p);
}
}
if(flag)
break;

}
}
int main()
{
while(~scanf("%s %s",a,b))
{
flag=0;
v=0;
memset(book,0,sizeof(book));
bfs(a[0]-'a',a[1]-'1',0);
if(flag)
{
printf("To get from %s to %s takes %d knight moves.\n",a,b,v);
}
}
return 0;
}
Starry_Sky_Dream 原创文章 50获赞 4访问量 2341 关注 私信
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: