您的位置:首页 > 其它

POJ - 1502(最短路Dijkstra or spfa)

2020-05-11 04:10 411 查看

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee’s research advisor, Jack Swigert, has asked her to benchmark the new system.

Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert.
Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.’’

``How is Apollo’s port of the Message Passing Interface (MPI) working out?’’ Swigert asked.

Not so well,'' Valentine replied.
To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.’’

``Is there anything you can do to fix that?’’

Yes,'' smiled Valentine.
There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.’’

``Ah, so you can do the broadcast as a binary tree!’’

``Not really a binary tree – there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don’t necessarily arrive at the destinations at the same time – there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.’’
Input
The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.
Output
Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.
Sample Input
5
50
30 5
100 20 50
10 x x 10
Sample Output
35
这个题意,就是求出来点1到达所有点的最短时间里面的那个最大的值。
比如 数据 第一行为 N N个点
后面 第二行 给出1个 表示e[1]][2]得距离为50,然后下一行 给出两个数据 表示 e[3][1] 和 e[3][2],接着 给出e[4][1] e[4][2] e[4][3] ,等等,x表示不相通。这就是所谓的斜三角输入,我也不懂哈,注意是无向图
嗯,我刚学,试着用DIJkstra 和 spfa 都写一次;
顺便了解了这个 atoi() 函数
atoi()函数会扫描参数 str 字符串,跳过前面的空白字符(例如空格,tab缩进等),
直到遇上数字或正负符号才开始做转换,而再遇到非数字或字符串结束时(’\0’)才结束转换,
并将结果返回。所以这里输入直接用char输入,如果是数字就可以直接改正,
而不用像我之前那样一位一位代换了。
先尝试dijkstra

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int e[105][105],dis[105],book[105];
int n,m;
char ch[15];
int minn,v,u;
void dijkstra()
{

memset(book,0,sizeof(book));
for(int i=1;i<=n;i++)
{
dis[i]=e[1][i];
}
for(int i=1;i<=n;i++)
{
minn=inf;
for(int j=1;j<=n;j++)
{
if(book[j]==0&&dis[j]<minn)
{
minn=dis[j];
u=j;
}
}
book[u]=1;
for(int j=1;j<=n;j++)
{
if(book[j]==0&&dis[j]>dis[u]+e[u][j])
dis[j]=e[u][j]+dis[u];
}
}
}
int main()
{
while(~scanf("%d",&n))
{
for(int i=2;i<=n;i++)
{
for(int j=1;j<=i-1;j++)
{
scanf("%s",ch);
if(ch[0]=='x')
e[i][j]=e[j][i]=inf;
else
e[i][j]=e[j][i]=atoi(ch);
}
}
for(int i=1;i<=n;i++)
e[i][i]=0;
dijkstra();
int mm=-inf;
for(int i=1;i<=n;i++)
mm=max(mm,dis[i]);
printf("%d\n",mm);
}
return 0;
}

很神奇的A了试试spfa

额,我还不会。。。。。。下次会了回头补上```

```cpp
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
#include<iostream>
using namespace std;

const int N=110,INF=(int)1e6;
int n,len;
char s[30];
int first[N],vis[N],d[N];
struct node{
int x,y,d,next;
}a[N*N];

void ins(int x,int y,int d)
{
len++;
a[len].x=x;a[len].y=y;a[len].d=d;
a[len].next=first[x];first[x]=len;
}

int main()
{
int i,j;
while(scanf("%d",&n)!=EOF)
{
len=0;
memset(first,0,sizeof(first));
for(i=2;i<=n;i++)
{
for(j=1;j<i;j++)
{
scanf("%s",s);
if(s[0]!='x')
{
int t=atoi(s);
ins(i,j,t);
ins(j,i,t);
}
}
}
d[1]=0;
for(i=2;i<=n;i++) d[i]=INF;
memset(vis,0,sizeof(vis));
queue<int> q;
q.push(1);
while(!q.empty())
{
int x=q.front();q.pop();
vis[x]=1;
for(i=first[x];i;i=a[i].next)
{
int y=a[i].y;
if(d[x]+a[i].d<d[y])
{
d[y]=d[x]+a[i].d;
if(!vis[y])
{
vis[y]=1;
q.push(y);
}
}
}
vis[x]=0;
}
int mx=-1;
for(i=1;i<=n;i++) mx=max(d[i],mx);
printf("%d\n",mx);
}
}
Starry_Sky_Dream 原创文章 50获赞 4访问量 2318 关注 私信
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: