您的位置:首页 > 其它

PAT1007 最大子数组问题

2018-03-16 09:36 295 查看

问题 1007. Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence
is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum
Subsequence is the continuous subsequence which has the largest sum of its
elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum
subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the
last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The
first line contains a positive integer K (<= 10000). The second line contains
K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the
first and the last numbers of the maximum subsequence. The numbers must be
separated by one space, but there must be no extra space at the end of a line.
In case that the maximum subsequence is not unique, output the one with the
smallest indices i and j (as shown by the sample case). If all the K numbers
are negative, then its maximum sum is defined to be 0, and you are supposed
to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4


题意理解

给定一个数组,求该数组的连续最大子数组,输出该连续最大子数组和、第一个元素以及最后一个元素。

题目分析

第一眼看到这个题目,我最初的想法是利用前缀和,统计前缀和sum[i] 表示{N1+N2+…+Ni}.所以对于任意一段区间[left,right]的和就是sum[right]-sum[left-1],外面套上两个for循环,时间复杂度为 O( n2n2) 。但是AC之后我看了一下大神的答案,这才想起其实以前算法导论做过一个类似的题目(习题4.1-5),复杂度仅仅为O(n),思想是从前往后累加,如果当前子数组的累加和小于0,则意味着最大子数组肯定不包括该子数组,所以果断舍弃,重新开始累加。

代码

复杂度为O(n2n2)的算法

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <cstring>
#include <map>
#include <climits>

using namespace std;

const int K = 10010;
int k;
int arr[K];

int main(int argc, char *argv[]) {

int maxn = INT_MIN;
int start,end;
int sub;
int flagOfAllNegative = 0;
int sum[K];

//freopen("Input.txt","r",stdin);

cin >> k;

for(int i = 1;i <= k;i++){
cin >> arr[i];
if(maxn < arr[i]){
maxn = arr[i];
start = i;
end = i;
}
}

//If all the maxn are negative,all the K numbers are negative
if(maxn < 0){
flagOfAllNegative = 1;
}

//Calculate the sum
sum[0] = 0;
for(int i = 1;i <= k;i++){
sum[i] = sum[i - 1] + arr[i];
//cout << sum[i] << ' ';
}

//Be careful,i should be bigger than j
for(int i = 2;i <= k;i++){
for(int j = 2;j < i;j++){
sub = sum[i] - sum[j-1];
if(maxn < sub){
start = j;
end = i;
maxn = sub;
}
}
}

//If all the K numbers are negative
if(flagOfAllNegative){
maxn = 0;
start = 1;
end = k;
}
//cout << start << ' ' << end << endl;
cout << maxn << ' ' << arr[start] << ' ' << arr[end];
return 0;
}


复杂度为O(nn)的算法

#include <iostream>
#include <vector>

using namespace std;

int main(int argc, char *argv[]) {
//freopen("Input.txt","r",stdin);
int k;
cin >> k;
vector<int> v(k);
int leftIndex = 0,rightIndex = k - 1,sum = -1,temp = 0,tempIndex = 0;
for(int i = 0;i < k;i++){
cin >> v[i];
temp = temp + v[i];
if(temp < 0){
temp = 0;
tempIndex = i + 1;
}else if(temp > sum){
sum = temp;
leftIndex = tempIndex;
rightIndex = i;
}
}
if(sum < 0) sum = 0;
cout << sum << ' ' << v[leftIndex] << ' ' << v[rightIndex];
return 0;
}


参考

https://www.liuchuo.net/archives/2122

http://www.cnblogs.com/Jiajun/archive/2013/05/08/3066979.html
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: