您的位置:首页 > 编程语言

1003. Emergency (25) PAT甲级刷题

2018-02-05 20:31 148 查看
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked
on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in
and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected
by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.

All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4

思路:求两点间最短距离的条数,考虑在迪杰斯特拉算法的框架上添加功能。

#include <iostream>
#include <vector>
#include <memory.h>
using namespace std;
int main()
{
const int MAX = 10000;
int n,m,c1,c2;
cin>>n>>m>>c1>>c2;
int vex
,num,dis
;
vector<int> pre
;
for(int i=0;i<n;++i){
cin>>num;
vex[i] = num;
pre[i].push_back(c1);
}
if(n==1){
cout<<'1'<<' '<<vex[c1];
return 0;
}
int i,j,w,edge

;
memset(edge,MAX,sizeof(edge));
while(m--){
cin>>i>>j>>w;
edge[i][j] = w;
edge[j][i] = w;
}
bool flag
= {0};
int amount
= {0};
for(int i=0;i<n;++i){
dis[i] = edge[c1][i];
if(dis[i]<MAX){
amount[i] = vex[c1] + vex[i];
}
}
dis[c1] = 0;
flag[c1] = 1;
int k;
for(int i=0;i<n;++i){
int min_ = MAX;
for(int j=0;j<n;++j){
if(!flag[j]&&dis[j]<min_){
min_ = dis[j];
k = j;
}
}
flag[k] = 1;
for(int j=0;j<n;++j){
int temp = min_+edge[k][j];
if(!flag[j]&&temp<dis[j]){
dis[j] = temp;
pre[j] = {k};
amount[j] = vex[j] + amount[k];
}
else if(!flag[j]&&temp==dis[j]){
pre[j].push_back(k);
amount[j] = amount[j]>vex[j] + amount[k]?amount[j]:vex[j] + amount[k];
}
}
}
int cnt = 0;
void DFS(vector<int> pre[],int,int,int &);
DFS(pre,c2,c1,cnt);
cout<<cnt<<' '<<amount[c2];
//cin.close();
return 0;
}

void DFS(vector<int> pre[],int c,int c1,int &cnt)
{
for(int i=0;i<pre[c].size();++i){
if(pre[c][i]==c1)
++cnt;
else
DFS(pre,pre[c][i],c1,cnt);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c 编程练习