您的位置:首页 > 理论基础 > 数据结构算法

SDUT 2119-数据结构实验之链表四:有序链表的归并

2017-12-23 20:15 375 查看
Problem Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入M与N的值;

第二行依次输入M个有序的整数;

第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

Example Input

6 5

1 23 26 45 66 99

14 21 28 50 100

Example Output

1 14 21 23 26 28 45 50 66 99 100

#include<stdio.h>
#include<stdlib.h>
typedef struct node
{
int data;
struct node *next;
}ST;
ST *creat(int n)
{
ST *head, *tail, *p;
head = (ST *)malloc(sizeof(ST));
head->next = NULL;
tail = head;
while(n--)
{
p = (ST *)malloc(sizeof(ST));
scanf("%d", &p->data);
p->next = NULL;
tail->next = p;
tail = p;
}
return head;
}
void merge(ST *head, ST *head1)
{
ST *q, *p, *tail;
q = head->next;
p = head1->next;
free(head1);
tail = head;
while(q && p)
{
if(q->data > p->data)
{
tail->next = p;
tail = p;
p = p->next;
}
else
{
tail->next = q;
tail = q;
q = q->next;
}
}
if(q)
tail->next = q;
else tail->next = p;
}
void input(ST *head)
{
ST *tail;
for(tail = head->next; tail != NULL; tail = tail->next)
{
printf("%d", tail->data);
if(tail->next != NULL) printf(" ");
else printf("\n");
}
}
int main()
{
ST *head, *head1;
int m, n;
scanf("%d %d", &m, &n);
head = creat(m);
head1 = creat(n);
merge(head, head1);
input(head);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: