您的位置:首页 > 编程语言 > Go语言

poj 3228 Gold Transportation 最小生成树+带权并查集 解题报告

2017-10-12 20:33 351 查看

Description

Recently, a number of gold mines have been discovered in Zorroming State. To protect this treasure, we must transport this gold to the storehouses as quickly as possible. Suppose that the Zorroming State consists of N towns and there are M bidirectional roads among these towns. The gold mines are only discovered in parts of the towns, while the storehouses are also owned by parts of the towns. The storage of the gold mine and storehouse for each town is finite. The truck drivers in the Zorroming State are famous for their bad temper that they would not like to drive all the time and they need a bar and an inn available in the trip for a good rest. Therefore, your task is to minimize the maximum adjacent distance among all the possible transport routes on the condition that all the gold is safely transported to the storehouses.

Input

The input contains several test cases. For each case, the first line is integer N(1<=N<=200). The second line is N integers associated with the storage of the gold mine in every towns .The third line is also N integers associated with the storage of the storehouses in every towns .Next is integer M(0<=M<=(n-1)*n/2).Then M lines follow. Each line is three integers x y and d(1<=x,y<=N,0

Output

For each case, output the minimum of the maximum adjacent distance on the condition that all the gold has been transported to the storehouses or “No Solution”.

Sample Input

4

3 2 0 0

0 0 3 3

6

1 2 4

1 3 10

1 4 12

2 3 6

2 4 8

3 4 5

0

Sample Output

6

思路

配图很清真。。。

最小生成树可以保证最小但是求不出具体得数值。

在每一次合并的时候带权并查集,并且判断金矿总量和仓库总量的关系。

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<vector>
using namespace std;
const int N=200,M=20000;
struct edge
{
int u,v,w;
}ed[M+5];
int n,m,w[N+5],s[N+5],father[N+5],answ,anss,ans;
bool cmp(edge a,edge b){return a.w<b.w;}
int find(int a){return father[a]==a?a:father[a]=find(father[a]);}
bool check()
{
for (int i=1;i<=n;i++)
{
int u=find(i);
if (s[u]<w[u]) return false;
}
return true;
}
void kruskal()
{
for (int i=1;i<=m;i++)
{
int u=ed[i].u,v=ed[i].v;
u=find(u),v=find(v);
if (u==v) continue;
father[u]=v;
w[v]+=w[u],w[u]=0;
s[v]+=s[u],s[u]=0;
ans=ed[i].w;
if (check()) return ;
}
}
int main()
{
while(~scanf("%d",&n))
{
answ=0,anss=0;
if (!n) break;
for (int i=1;i<=n;i++)
father[i]=i;
for (int i=1;i<=n;i++)
scanf("%d",&w[i]),answ+=w[i];
for (int i=1;i<=n;i++)
scanf("%d",&s[i]),anss+=s[i];
if (answ>anss) {printf("No Solution\n");continue;}
scanf("%d",&m);
for (int i=1;i<=m;i++)
scanf("%d%d%d",&ed[i].u,&ed[i].v,&ed[i].w);
if (check()) {printf("0\n");continue;}
sort(ed+1,ed+1+m,cmp);
kruskal();
if (check()) printf("%d\n",ans);
else printf("No Solution\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: