您的位置:首页 > 理论基础 > 数据结构算法

SDUT 3362 数据结构实验之图论六:村村通公路(并查集)

2017-10-09 18:50 295 查看

数据结构实验之图论六:村村通公路

Time Limit: 1000MSMemory Limit: 65536KB

SubmitStatistic

Discuss

Problem Description

当前农村公路建设正如火如荼的展开,某乡镇政府决定实现村村通公路,工程师现有各个村落之间的原始道路统计数据表,表中列出了各村之间可以建设公路的若干条道路的成本,你的任务是根据给出的数据表,求使得每个村都有公路连通所需要的最低成本。

Input

连续多组数据输入,每组数据包括村落数目N(N <= 1000)和可供选择的道路数目M(M <= 3000),随后M行对应M条道路,每行给出3个正整数,分别是该条道路直接连通的两个村庄的编号和修建该道路的预算成本,村庄从1~N编号。 

Output

输出使每个村庄都有公路连通所需要的最低成本,如果输入数据不能使所有村庄畅通,则输出-1,表示有些村庄之间没有路连通。 

Example Input

5 8
1 2 12
1 3 9
1 4 11
1 5 3
2 3 6
2 4 9
3 4 4
4 5 6


Example Output

19


Hint

解决方法:并查集
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct link_road
{
int a,b,cost;
}p[3500];
int father[1500];
int cmp(struct link_road p1,struct link_road p2)
{
return p1.cost<p2.cost;
}
int finda(int i)
{
while(i!=father[i])
i=father[i];
return i;
}
void mergea(int a,int b)
{
int fa=finda(a);
int fb=finda(b);
if(fa!=fb)
father[fa]=fb;
}
int main()
{
int n,m;
while(scanf("%d %d",&n,&m)!=EOF)
{
memset(p,0,sizeof(p));
for(int i=1;i<=n;i++)
father[i]=i;
for(int i=0;i<m;i++)
scanf("%d %d %d",&p[i].a,&p[i].b,&p[i].cost);
sort(p,p+m,cmp);
int cnt=0,sum=0;
for(int i=0;i<m;i++)
{
if(finda(p[i].a)!=finda(p[i].b))
{
mergea(p[i].a,p[i].b);
cnt++;
sum+=p[i].cost;
}
}
//printf("cnt=%d\n",cnt);
if(cnt==n-1)
printf("%d\n",sum);
else
printf("-1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: