您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表九:双向链表

2017-09-28 22:39 330 查看
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/li1351026473/article/details/78128927

数据结构实验之链表九:双向链表

Time Limit: 1000MS Memory Limit: 65536KB SubmitStatistic

Problem Description

学会了单向链表,我们又多了一种解决问题的能力,单链表利用一个指针就能在内存中找到下一个位置,这是一个不会轻易断裂的链。但单链表有一个弱点——不能回指。比如在链表中有两个节点A,B,他们的关系是B是A的后继,A指向了B,便能轻易经A找到B,但从B却不能找到A。一个简单的想法便能轻易解决这个问题——建立双向链表。在双向链表中,A有一个指针指向了节点B,同时,B又有一个指向A的指针。这样不仅能从链表头节点的位置遍历整个链表所有节点,也能从链表尾节点开始遍历所有节点。对于给定的一列数据,按照给定的顺序建立双向链表,按照关键字找到相应节点,输出此节点的前驱节点关键字及后继节点关键字。

Input

第一行两个正整数n(代表节点个数),m(代表要找的关键字的个数)。第二行是n个数(n个数没有重复),利用这n个数建立双向链表。接下来有m个关键字,每个占一行。

Output

对给定的每个关键字,输出此关键字前驱节点关键字和后继节点关键字。如果给定的关键字没有前驱或者后继,则不输出。
注意:每个给定关键字的输出占一行。
           一行输出的数据之间有一个空格,行首、行末无空格。

 

Example Input

10 31 2 3 4 5 6 7 8 9 0350

Example Output

2 44 69


    #include <stdio.h>  
    #include <stdlib.h>  
    struct node  
    {  
        int data;  
        struct node*next;  
    };  
    struct node *create(int n)  
    {  
        struct node *head,*p,*tail;  
        int i;  
        head=(struct node*)malloc(sizeof(struct node));  
        head->next=NULL;  
        tail=head;  
        for(i=0;i<n;i++)  
        {  
            p=(struct node*)malloc(sizeof(struct node));  
            p->next=NULL;  
            scanf("%d",&p->data);  
            tail->next=p;  
            tail=p;  
            tail->next=NULL;  
        }  
        return (head);  
    };  
    void cha(struct node *h,int m)  
    {  
        struct node *p=h->next;  
        if(p->data==m)  
        {  
            printf("%d\n",p->next->data);  
        }  
        else  
        {  
            while(p->next->data!=m)  
            {  
                p=p->next;  
            }  
            if(p->next->next!=NULL)  
            {  
                printf("%d %d\n",p->data,p->next->next->data);  
            }  
            else  
            {  
                printf("%d\n",p->data);  
            }  
        }  
    }  
    int main()  
    {  
        int n,m,x,i;  
        scanf("%d %d",&n,&m);  
        struct node*p;  
        p=create(n);  
        for(i=0;i<m;i++)  
        {  
            scanf("%d",&x);  
            cha(p,x);  
        }  
        return 0;  
    }  


//C++

#include <iostream>


using namespace std;
typedef struct node
{
    int data;
    node *next;
    node *before;
};


node *create(int n)
{
    node *head,*p,*tail;
    head=new node;
    head->next=NULL;
    tail=head;
    for(int i=0;i<n;i++)
    {
        p=new node;
        cin>>p->data;
        p->next=NULL;
        tail->next=p;
        p->before=tail;
        tail=p;
    }
    return head;
}
void chaxun(node *h,int x)
{
    node *p=h->next;
    while(p)
    {
        if(p->data==x)
            break;
        else
            p=p->next;
    }
    if(p->before!=h&&p->next!=NULL)
        cout<<p->before->data<<" "<<p->next->data<<endl;
    else if(p->before!=h&&p->next==NULL)
        cout<<p->before->data<<endl;
    else
        cout<<p->next->data<<endl;


}
int main()
{
    int n,m;
    cin>>n>>m;
    node *p;
    p=create(n);


    int x;
    for(int i=0;i<m;i++)
    {
        cin>>x;
        chaxun(p,x);
    }
    return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: