您的位置:首页 > 编程语言 > Go语言

UVA - 11292 Dragon of Loowater

2017-08-30 14:40 281 查看

https://vjudge.net/problem/UVA-11292

Description

Once upon a time, in the

Kingdom of Loowater, a minor

nuisance turned into a

major problem.

The shores of Rellau

Creek in central Loowater

had always been a prime

breeding ground for geese.

Due to the lack of predators,

the geese population was out………………………………………..(actually this area should be a picture)

of control. The people of

Loowater mostly kept clear

of the geese. Occasionally,

a goose would attack one of

the people, and perhaps bite

off a finger or two, but in

general, the people tolerated

the geese as a minor nuisance.

One day, a freak mutation

occurred, and one

of the geese spawned a

multi-headed fire-breathing

dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp.

Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon

and save the kingdom.

The knights explained: “To slay the dragon, we must chop off all its heads. Each knight can chop

off one of the dragon’s heads. The heads of the dragon are of different sizes. In order to chop off a

head, a knight must be at least as tall as the diameter of the head. The knights’ union demands that

for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the

knight’s height.”

Would there be enough knights to defeat the dragon? The king called on his advisors to help him

decide how many and which knights to hire. After having lost a lot of money building Mir Park, the

king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to

help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to

a crisp!

Input

The input contains several test cases. The first line of each test case contains two integers between 1 and

20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in

the kingdom. The next n lines each contain an integer, and give the diameters of the dragon’s heads,

in centimetres. The following m lines each contain an integer, and specify the heights of the knights of

Loowater, also in centimetres.

The last test case is followed by a line containing ‘0 0’.

Output

For each test case, output a line containing the minimum number of gold coins that the king needs to

pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the

line ‘Loowater is doomed!’.

Sample Input

2 3

5

4

7

8

4

2 1

5

5

10

0 0

Sample Output

11

Loowater is doomed!

题解:

显然这道题就是一个排序,然后我们进行贪心,如果当前的这个骑士可以砍掉当前的这个头,我们就进行操作,否则就换下一个骑士,当所有头都被砍完输出答案或者没有被砍完输出无解即可。

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=100000;
int n,m,a[MAXN],b[MAXN];
int main(){
while(scanf("%d%d",&n,&m)!=EOF&&(n||m)){
for(register int i=1;i<=n;i++) scanf("%d",&a[i]);
for(register int j=1;j<=m;j++) scanf("%d",&b[j]);
sort(a+1,a+n+1);sort(b+1,b+m+1);
int cur1=1,cur2=1,sum=0;
while(cur1<=n&&cur2<=m){
if(a[cur1]<=b[cur2]){
sum+=b[cur2];
cur1++;cur2++;
}else{
cur2++;
}
}
if(cur1==n+1) printf("%d\n",sum);
else        printf("Loowater is doomed!\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: