您的位置:首页 > 其它

HDU1160DP最长上升子序列微整形

2017-08-14 18:43 162 查看


FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17073    Accepted Submission(s): 7554
Special Judge


Problem Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information
for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 

 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m
then it must
be the case that 

W[m[1]] < W[m[2]] < ... < W[m
]

and 

S[m[1]] > S[m[2]] > ... > S[m
]

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 

 

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

 

Sample Output

4
4
5
9
7

 

Source

Zhejiang University Training Contest 2001

思路:

先按照重量排序,然后找出LIS最长上升子序列。
#include<cstdio>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
struct Mice{
int w,v,id;
}mice[1010];
int dp[1010];
int pre[1010];
bool cmp(Mice a,Mice b)
{
return a.w>b.w;
}

int main()
{
int s=0;
while(scanf("%d%d",&mice[s].w,&mice[s].v)!=EOF)
{
mice[s].id=s+1;
s++;
}
sort(mice,mice+s,cmp);
memset(pre,-1,sizeof(pre));
for(int i=0;i<s;i++)
dp[i]=1;
for(int i=0;i<s;i++)
for(int j=0;j<i;j++)
{
if(mice[j].w>mice[i].w&&mice[j].v<mice[i].v)
{
if(dp[i]<dp[j]+1)
{
dp[i]=dp[j]+1;
pre[i]=j;
}
}
}
int ans=0;
int p;
for(int i=0;i<s;i++)
{
if(dp[i]>ans)
{
ans=dp[i];
p=i;
}
}
printf("%d\n",dp[p]);
while(p!=-1)
{
printf("%d\n",mice[p].id);
p=pre[p];
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: