您的位置:首页 > 编程语言 > Java开发

HDOJ 1241 油田 DFS初级算法 java代码实现 详细注释

2017-04-22 00:49 465 查看
初级的DFS算法:

题目链接:点击打开链接

基本解题思路:就是往油田的上、下、左、右、左上、左下,右上、右下八个方向遍历

Oil Deposits

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 30130    Accepted Submission(s): 17424
[/b]

[align=left]Problem Description[/align]
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

[align=left]Input[/align]
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

[align=left]Output[/align]
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

[align=left]Sample Input[/align]

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

[align=left]Sample Output[/align]

0
1
2
2

import java.util.*;
class Main{
public static void main(String args[]){
Scanner sc=new Scanner(System.in);
while(sc.hasNext()){
int n=sc.nextInt();
int m=sc.nextInt();
if(n==0&&m==0){
break;
}
char a[][]=new char
[m];			//字符数组装油田和*
boolean vis[][]=new boolean
[m];	//标记数组,说明该位置是否被用过
for(int i=0;i<n;i++){
String str=sc.next();
a[i]=str.toCharArray();
}
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
vis[i][j]=true;			//初始化标记数组,为true说明没被用过
}
}
int count=0;		//油田数量
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
if(a[i][j]=='@'&&vis[i][j]){	//如果这个位置是油田,且没用被用过
vis[i][j]=false;	//标记这个位置被用过
dfs(a,vis,i,j,n,m);	//从这个位置开始搜索

count++;
}
}
}
System.out.println(count);
}
}
public static void dfs(char a[][],boolean vis[][],int x,int y,int n,int m){
int t[][]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
//上下左右,左上左下,右上右下,八个方向
for(int i=0;i<8;i++){
int nx=x+t[i][0];		//遍历该位置的八个方向
int ny=y+t[i][1];
if(nx>=0&&nx<n&&ny>=0&&ny<m){		//当新的位置还在范围内时,不会越界
if(a[nx][ny]=='@'&&vis[nx][ny]){
//如果还是油田,则接着搜索该位置的八个方向,并标记此位置已经被用过
vis[nx][ny]=false;
dfs(a,vis,nx,ny,n,m);
}
}
}
}
}


附:BFS  队列和循环队列 代码: 点击打开链接
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dfs java 杭电