您的位置:首页 > 编程语言 > C语言/C++

L1-039. 古风排版

2017-03-27 22:04 357 查看


L1-039. 古风排版

时间限制

400 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

陈越

中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。

输入格式:

输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:

按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)
输入样例:
4
This is a test case

输出样例:
asa T
st ih
e tsi
ce s


#include <iostream>
#include <stdio.h>
#include <string>
#include <vector>
#include <algorithm>
#include <set>
#include <map>
using namespace std;
int main()
{
int n;
cin >> n;
getchar();
string str;
getline(cin, str);
int length = str.size();
int col = length % n == 0 ? length / n : length / n + 1;
//int col = (str.length() - 1) / n + 1;
//char a[101][1001] = {' '};
vector<vector<char> > v(n, vector<char>(col, ' '));
int Index = 0;
for(int i = 0; i < col; i++){
for(int j = 0; j < n; j++){
if (Index < str.length()){
v[j][col - i - 1] = str[Index++];
}
}
}
for(int i = 0; i < n; i++){
for(int j = 0; j < col; j++){
cout << v[i][j];
}
cout << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  cpp stl 编程 水题