您的位置:首页 > 编程语言 > C语言/C++

1059. C语言竞赛(20)

2017-03-15 09:17 204 查看


1059. C语言竞赛(20)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

C语言竞赛是浙江大学计算机学院主持的一个欢乐的竞赛。既然竞赛主旨是为了好玩,颁奖规则也就制定得很滑稽:

0. 冠军将赢得一份“神秘大奖”(比如很巨大的一本学生研究论文集……)。

1. 排名为素数的学生将赢得最好的奖品 —— 小黄人玩偶!

2. 其他人将得到巧克力。

给定比赛的最终排名以及一系列参赛者的ID,你要给出这些参赛者应该获得的奖品。

输入格式:

输入第一行给出一个正整数N(<=10000),是参赛者人数。随后N行给出最终排名,每行按排名顺序给出一位参赛者的ID(4位数字组成)。接下来给出一个正整数K以及K个需要查询的ID。

输出格式:

对每个要查询的ID,在一行中输出“ID: 奖品”,其中奖品或者是“Mystery Award”(神秘大奖)、或者是“Minion”(小黄人)、或者是“Chocolate”(巧克力)。如果所查ID根本不在排名里,打印“Are you kidding?”(耍我呢?)。如果该ID已经查过了(即奖品已经领过了),打印“ID: Checked”(不能多吃多占)。
输入样例:
6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

输出样例:
8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?


#include <iostream>
#include <vector>
#include <stdio.h>
#include <algorithm>
#include <iomanip>
#include <string>
#include <cstdio>
#include <string.h>
#include <set>
#include <cmath>
using namespace std;
bool isPrime(int a)
{
if(a<=1){
return false;
}
for(int i=2;i<=sqrt(a);i++){
if(a%i==0){
return false;
}
}
return true;
}
int main()
{
int N,K;
cin>>N;
set<int> s1;
vector<int> v1;
for(int i=0;i<N;i++){
int temp;
cin>>temp;
v1.push_back(temp);
}
cin>>K;
for(int i=0;i<K;i++){
int temp;
cin>>temp;
if(s1.find(temp)==s1.end()){
if(temp==v1[0]){
printf("%04d: Mystery Award\n",temp);
s1.insert(temp);
}else {
int isIn = 0;
for(int j=1;j<v1.size();j++){
if(v1[j]==temp){
isIn = 1;
if(isPrime(j+1)){
printf("%04d: Minion\n",temp);
s1.insert(temp);
break;
}else {
printf("%04d: Chocolate\n",temp);
s1.insert(temp);
break;
}
}
}
if(!isIn){
printf("%04d: Are you kidding?\n",temp);
}
}
}else {
printf("%04d: Checked\n",temp);
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息