您的位置:首页 > 其它

Romantic(扩展欧几里得)注意数据范围

2017-03-01 19:44 211 查看

Romantic

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5697 Accepted Submission(s): 2421


[align=left]Problem Description[/align]
The Sky is Sprite.

The Birds is Fly in the Sky.

The Wind is Wonderful.

Blew Throw the Trees

Trees are Shaking, Leaves are Falling.

Lovers Walk passing, and so are You.

................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!

Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

[align=left]Input[/align]
The input contains multiple test cases.

Each case two nonnegative integer a,b (0<a, b<=2^31)

[align=left]Output[/align]
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.

[align=left]Sample Input[/align]

77 51
10 44
34 79

[align=left]Sample Output[/align]

2 -3
sorry
7 -3
#include<cstdio>
#include<iostream>
using namespace std;
long long g;
void exgcd(long long a,long long b,long long & x,long long &y)
{
if(b==0)
{
g=a;
x=1;
y=0;
}
else
{
exgcd(b,a%b,y,x);
y-=x*(a/b);
}
}
int main()
{
//ax+by=1;
long long a,b,x,y;
while(~scanf("%lld%lld",&a,&b))
{
exgcd(a,b,x,y);
if(g!=1) puts("sorry");
else
{
x%=b;
while(x<0) x+=b;
y=(1-a*x)/b;
printf("%lld %lld\n",x,y);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: