您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表五:单链表的拆分

2017-02-26 16:09 375 查看

数据结构实验之链表五:单链表的拆分

[align=center]Time Limit: 1000MSMemory Limit: 65536KB[/align]
[align=center][/align]

Problem Description

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

Input

第一行输入整数N;;

第二行依次输入N个整数。

Output

第一行分别输出偶数链表与奇数链表的元素个数;

第二行依次输出偶数子链表的所有数据;

第三行依次输出奇数子链表的所有数据。

Example Input

10
1 3 22 8 15 999 9 44 6 1001


Example Output

4 6
22 8 44 6
1 3 15 999 9 1001


Hint

不得使用数组!
代码如下:
#include<stdio.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node *Creat(int n)
{
struct node *head,*p;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
int i;
for(i=0; i<n; i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=NULL;
p->next=head->next;
head->next=p;
}
return head;
};
struct node *Solit(struct node *head1)
{
int temp1=0;
int temp2=0;
struct node *head2,*p,*q;
head2=(struct node *)malloc(sizeof(struct node));
head2->next=NULL;
p=head1->next;
head1->next=NULL;
q=p->next;
while(p)
{
if(p->data%2==0)
{
p->next=head1->next;
head1->next=p;
temp1++;
}
else
{
p->next=head2->next;
head2->next=p;
temp2++;
}
p=q;
if(q)
q=q->next;
}
printf("%d %d\n",temp1,temp2);
return head2;
}
void Show(struct node *head)
{
struct node *p;
p=head->next;
while(p)
{
if(p->next==NULL)
printf("%d\n",p->data);
else
printf("%d ",p->data);
p=p->next;
}
}
void main()
{
int n;
struct node *head1,*head2;
scanf("%d",&n);
head1=Creat(n);
head2=Solit(head1);
Show(head1);
Show(head2);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: