您的位置:首页 > 编程语言 > C语言/C++

PAT甲级1053

2017-01-30 16:46 169 查看


1053. Path of Equal Weight (30)

时间限制

10 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes
along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower
number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.



Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains
N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]


where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of
the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2,
..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ... k, and Ak+1 > Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2


#include<cstdio>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
const int maxn = 100;
int N, M,S;
vector<int> children[maxn];
int weight[maxn];
vector<int> path;
vector<vector<int> > paths;
void DFS(int root, int sumweight,vector<int> path)
{
if (!children[root].size())
{
if (sumweight == S)
paths.push_back(path);
return;
}
for (int i = 0; i < children[root].size(); i++)
{
int t = children[root][i];
vector<int> temppath = path;
temppath.push_back(weight[t]);
DFS(t, sumweight + weight[t],temppath);
}
}
bool cmp(vector<int> v1, vector<int> v2)
{
bool flag = false;
for (int i = 0; i < min(v1.size(), v2.size()); i++)
{
if (v1[i] > v2[i])
{
flag = true;
break;
}
else if (v1[i] < v2[i])
{
flag = false;
break;
}
}
return flag;
}
int main()
{
scanf("%d %d %d", &N, &M, &S);
for (int i = 0; i < N; i++)
{
scanf("%d", &weight[i]);
}
int father, k, child;
for (int i = 0; i < M; i++)
{
scanf("%d %d", &father, &k);
while (k--)
{
scanf("%d", &child);
children[father].push_back(child);
}
}
path.push_back(weight[0]);
DFS(0, weight[0], path);
sort(paths.begin(), paths.end(), cmp);
for (int i = 0; i < paths.size(); i++)
{
for (int j = 0; j < paths[i].size(); j++)
{
printf("%d", paths[i][j]);
if (j != paths[i].size() - 1)
printf(" ");
else
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息