您的位置:首页 > 理论基础 > 数据结构算法

数据结构顺序表应用5:有序顺序表归并

2017-01-16 21:09 225 查看
顺序表应用5:有序顺序表归并

Time Limit: 100MS Memory Limit: 800KB

Problem Description

已知顺序表A与B是两个有序的顺序表,其中存放的数据元素皆为普通整型,将A与B表归并为C表,要求C表包含了A、B表里所有元素,并且C表仍然保持有序。

Input

输入分为三行:

第一行输入m、n(1<=m,n<=10000)的值,即为表A、B的元素个数;

第二行输入m个有序的整数,即为表A的每一个元素;

第三行输入n个有序的整数,即为表B的每一个元素;

Output

输出为一行,即将表A、B合并为表C后,依次输出表C所存放的元素。

Example Input

5 3

1 3 5 6 9

2 4 10

Example Output

1 2 3 4 5 6 9 10

Hint

思路:创建两个表合并起来,还是很简单的一道题,主要就是合并怎么操作,因为他已经是排好顺序的,有小到大,直接用i,j分别代表两个表的开始,比较对应大小,谁小把谁存起来,那个表先存完了,另一个表剩下的直接接上去就好了。

#include<stdio.h>
#include<stdlib.h>
typedef struct node
{
int data[100010];
int last;
}ST;
void creat(ST *head)
{
int i;
for(i = 0; i < head->last; i++)
{
scanf("%d", &head->data[i]);
}
}
void bine(ST *head, ST *tail, ST *p)
{
int i, j, k;
i = 0; j = 0; k = 0;
while(i < head->last && j < tail->last)
{
if(head->data[i] < tail->data[j])
{
p->data[k++] = head->data[i++];
}
else
{
p->data[k++] = tail->data[j++];
}
}
if(i == head->last)
{
for(j = j; j < tail->last; j++)
{
p->data[k++] = tail->data[j];
}
}
if(j == tail->last)
{
for(i = i; i < head->last; i++)
{
p->data[k++] = tail->data[i];
}
}
p -> last = k;
}
int main()
{
ST *head, *tail, *p;
int m, n, i;
head = (ST *)malloc(sizeof(ST));
tail = (ST *)malloc(sizeof(ST));
p = (ST *)malloc(sizeof(ST));
scanf("%d %d", &head->last, &tail->last);
creat(head);
creat(tail);
bine(head,tail,p);
for(i = 0; i < p->last; i++)
{
printf("%d", p->data[i]);
if(i != p -> last - 1) printf(" ");
else printf("\n");
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构 c语言