您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表二:逆序建立链表(附带链表的释放)

2017-01-12 17:26 218 查看
数据结构实验之链表二:逆序建立链表(附带链表的释放)

Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

Input

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。

Output

依次输出单链表所存放的数据。

Example Input

10

11 3 5 27 9 12 43 16 84 22

Example Output

22 84 16 43 12 9 27 5 3 11

Hint

不能使用数组!

#include <stdio.h>
#include <stdlib.h>

typedef struct linkedlist
{
int date;
struct linkedlist *next;
}st;

st * build(int n)
{
st *head, *p;
head = (st *)malloc(sizeof(st));
head->next = NULL;
for(int i = 0; i < n; i++)
{
p = (st *)malloc(sizeof(st));
scanf("%d", &p->date);
p->next = head->next;
head->next = p;
}
return head;
}

void pri(st *head)
{
st *p;
p = head->next;
while(p != NULL)
{
printf("%d%c", p->date, p->next == NULL? '\n': ' ');
p = p->next;
}
}

int main()
{
st *head, *p;
int n;
scanf("%d", &n);
head = build(n);
pri(head);
for(; head != NULL; head = p)
{
p = head->next;
free(head);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息