您的位置:首页 > 编程语言 > C语言/C++

PAT乙级1028

2017-01-08 23:43 183 查看
1028. 人口普查(20)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5

John 2001/05/12

Tom 1814/09/06

Ann 2121/01/30

James 1814/09/05

Steve 1967/11/20

输出样例:
3 Tom John

#include<iostream>
#include<stdio.h>
#include<vector>
#include<map>
#include<set>
#include<string>
#include<algorithm>
using namespace std;
struct person
{
string name;
int year, month, day;
/*void operator=(person p)
{
year = p.year;
month = p.month;
day = p.day;
name = p.name;
}
bool operator==(person p)
{
if (year == p.year&&month == p.month&&day == p.day)
return 1;
else
return false;
}*/
int operator<(person p)
{
if (year != p.year)
return year < p.year;
else if (month != p.month)
return month < p.month;
else if (day != p.day)
return day < p.day;
else
return 0;
}

};
/*bool lessequal(person p1, person p2)
{
if (p1.year != p2.year)
return p1.year < p2.year;
else if (p1.month != p2.month)
return p1.month < p2.month;
else if (p1.day != p2.day)
return p1.day < p2.day;
else
return 1;
}
bool morequal(person p2, person p1)
{
if (p1.year != p2.year)
return p1.year < p2.year;
else if (p1.month != p2.month)
return p1.month < p2.month;
else if (p1.day != p2.day)
return p1.day < p2.day;
else
return 1;
}*/
int main()
{
int N;
cin >> N; person p; vector<person> v; bool valid;
while (N--)
{
valid = false;
cin >> p.name;
scanf(" %d/%d/%d", &p.year, &p.month, &p.day);
if (p.year > 1814&&p.year<2014)
{
valid = true;
}
if (p.year == 1814)
{
if (p.month > 9)
{
valid = true;
}
else if (p.month == 9)
{
if (p.day >= 6)
valid = true;
}
}
if (p.year == 2014)
{
if (p.month < 9)
{
valid = true;
}
else if (p.month == 9)
{
if (p.day <= 6)
valid = true;
}
}
if (valid)
v.push_back(p);
}
sort(v.begin(), v.end());
//person oldest, youngest;
/*if (v.size()>0)
{
oldest = v[0], youngest = v[0];
for (int i = 0; i < v.size(); i++)
{
if (morequal(v[i], youngest))
youngest = v[i];
if (lessequal(v[i], oldest))
oldest = v[i];
}
}*/

if (v.size() > 0)
cout << v.size() << " " << v[0].name << " " << v[v.size() - 1].name;
//cout << v.size() << " " <<oldest.name << " " << youngest.name;
else
cout << 0;
v.clear();
return 0;
}
/*这题主要有两点,特判即0个有效记录的情况,然后就是那个对记录有效性的判断。
然后这题让困扰我很久的一个问题得到解决,那就是自定义sort函数中的cmp函数
或重载要比较的元素所属类的小于号时,要想不报invalid comparator错误时,
那么对相等情况的处理必须是返回0或者false,注意-1并不是对于所有编译器而
言都表示false,所以不能返回-1,不等的情况自定义即可。上述代码中注释部分
是用于手动排序,我上传到OJ的代码是重载小于号的解法的代码,不想手动,^_^
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息