您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表二:逆序建立链表

2016-11-23 21:54 232 查看


Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。


Input

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。


Output

依次输出单链表所存放的数据。


Example Input

10

11 3 5 27 9 12 43 16 84 22



Example Output

22 84 16 43 12 9 27 5 3 11



Hint

不能使用数组!

源代码
#include<stdio.h>
#include<stdlib.h>
struct node
{
int shu;
struct node *next;
};
int main()
{
struct node *head,*q,*p;
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
q=head;
int n;
scanf("%d",&n);
while(n--)
{
p=(struct node*)malloc(sizeof(struct node));
scanf("%d",&p->shu);
p->next=head->next;
head->next=p;
}
q=head->next;
while(q!=NULL)
{
if(q->next!=NULL)
{
printf("%d ",q->shu);
}
else printf("%d\n",q->shu);
q=q->next;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: