您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表六:有序链表的建立

2016-11-12 21:00 239 查看

数据结构实验之链表六:有序链表的建立

Time Limit: 1000MS
Memory Limit: 65536KB
[align=center][/align]

Problem Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

Input

第一行输入整数个数N;

第二行输入N个无序的整数。

Output

依次输出有序链表的结点值。

Example Input

6
33 6 22 9 44 5


Example Output

5 6 9 22 33 44


Hint

不得使用数组!

Author

 
#include<stdio.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node *creat(struct node *head,int n)
{
int i;
struct node *p,*q;
q=head;
for(i=0;i<n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=q->next;
q->next=p;
q=p;
}
return head;
}
int main()
{
int i,j,n,m,k,t;
struct node *head,*p,*q,*tail;
scanf("%d",&n);
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
head=creat(head,n);
q=head;
for(i=0;i<n-1;i++)
{
q=q->next;
p=q->next;
for(j=i+1;j<n;j++)
{
if(q->data>p->data)
{
t=q->data;
q->data=p->data;
p->data=t;
}
p=p->next;
}
}
p=head;
p=p->next;
i=0;
while(p!=NULL)
{
if(i==0)
printf("%d",p->data);
else
printf(" %d",p->data);
p=p->next;
i++;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: