您的位置:首页 > 编程语言 > C语言/C++

杭电 1002 大数相加 【关键语句:sum=a[i]-'0'+b[j]-'0'+carry;c[i]='0'+sum%10;//-‘0’字符串转换成数字-‘0’,数字转换成字符串+‘0’】

2016-10-24 22:35 429 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 324547    Accepted Submission(s): 63050


[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

 

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

 

[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
int main()
{
char a[1024],b[1024],c[1024];
int n,t,l1,l2,l,i,j,carry,sum;
while(EOF!=scanf("%d",&n))
{
for(t=0;t<n;t++)
{
if(t!=0)
printf("\n");
carry=0;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
scanf("%s%s",&a,&b);

l1=strlen(a);l2=strlen(b);

if(l1>l2)
{
for(i=l1-1,j=l2-1;j>=0;i--,j--)
{
sum=a[i]-'0'+b[j]-'0'+carry;//由字符串转换为数字——-‘0”
//这句还有个error,就是自动默认了i和j相等= =
c[i]='0'+sum%10;//由数字转换为字符串
carry=sum/10;
}
for(;i>=0;i--)//处理剩下一部分
                {
sum=a[i]-'0'+carry;
c[i]='0'+sum%10;
carry=sum/10;
}
}
else
{
for(i=l1-1,j=l2-1;i>=0;i--,j--)
{
sum=a[i]-'0'+b[j]-'0'+carry;
c[j]='0'+sum%10;
carry=sum/10;
}
for(;j>=0;j--)
{
sum=b[j]-'0'+carry;
c[j]='0'+sum%10;//和上面的不太一样啊...
carry=sum/10;
}
}
l=l1>l2?l1:l2;
printf("Case %d:\n",t+1);
printf("%s + %s = ",a,b);
if(carry!=0)  printf("%d",carry);
printf("%s\n",c);

}
}
return 0;
}
#include<stdio.h>
#include<string.h>
int main()
{
char a[1024],b[1024],c[1024];
int n,t,l1,l2,l,i,j,carry,sum;
while(EOF!=scanf("%d",&n))
{
for(t=0;t<n;t++)
{
if(t!=0)
printf("\n");
carry=0;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
scanf("%s%s",&a,&b);

l1=strlen(a);l2=strlen(b);

if(l1>l2)
{
for(i=l1-1,j=l2-1;j>=0;i--,j--)
{
sum=a[i]-'0'+b[j]-'0'+carry;//由字符串转换为数字——-‘0”
//这句还有个error,就是自动默认了i和j相等= =
c[i]='0'+sum%10;//由数字转换为字符串
carry=sum/10;
}
for(;i>=0;i--)//处理剩下一部分
{
sum=a[i]-'0'+carry;
c[i]='0'+sum%10;
carry=sum/10;
}
}
else
{
for(i=l1-1,j=l2-1;i>=0;i--,j--)
{
sum=a[i]-'0'+b[j]-'0'+carry;
c[j]='0'+sum%10;
carry=sum/10;
}
for(;j>=0;j--)
{
sum=b[j]-'0'+carry;
c[j]='0'+sum%10;//和上面的不太一样啊...
carry=sum/10;
}
}
l=l1>l2?l1:l2;
printf("Case %d:\n",t+1);
printf("%s + %s = ",a,b);
if(carry!=0)  printf("%d",carry);
printf("%s\n",c);

}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c语言 vc 6 杭电