您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表五:单链表的拆分

2016-09-29 15:13 381 查看



数据结构实验之链表五:单链表的拆分

Time Limit: 1000MS Memory Limit: 65536KB


Problem Description

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。


Input

第一行输入整数N;;

第二行依次输入N个整数。


Output

第一行分别输出偶数链表与奇数链表的元素个数; 

第二行依次输出偶数子链表的所有数据;

第三行依次输出奇数子链表的所有数据。


Example Input

10
1 3 22 8 15 999 9 44 6 1001



Example Output

4 6
22 8 44 6
1 3 15 999 9 1001



Code realization

#include <stdio.h>
#include <stdlib.h>
typedef struct LNode
{
int data;
struct LNode *next;
}LNode;
int num1 = 0,num2 = 0;
LNode *input(int n)
{
LNode *head, *tail, *p;
head = (LNode*)malloc(sizeof(LNode));
tail = head;
for(int i=0;i<n;i++)
{
p = (LNode*)malloc(sizeof(LNode));
scanf("%d",&p->data);
tail->next = p;
tail = p;
tail->next = NULL;
}
return head;
}
void split(LNode *head,LNode *head1,LNode *head2)
{
LNode *p, *tail1, *tail2;
p = head->next;
tail1 = head1;
tail2 = head2;
while(p)
{
if(p->data%2==0)
{
tail1->next = p;
tail1 = p;
num1++;
}
else
{
tail2->next = p;
tail2 = p;
num2++;
}
p = p->next;
}
tail1->next = NULL;
tail2->next = NULL;
}
void output(LNode *head)
{
LNode *p;
p = head->next;
while(p)
{
printf("%d",p->data);
p = p->next;
if(p)
printf(" ");
else
printf("\n");
}
}

int main()
{
LNode *head, *head1, *head2;
int n;
scanf("%d",&n);
head = input(n);
head1 = (LNode*)malloc(sizeof(LNode));
head2 = (LNode*)malloc(sizeof(LNode));
split(head,head1,head2);
printf("%d %d\n",num1,num2);
output(head1);
output(head2);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息