您的位置:首页 > 编程语言 > Go语言

POJ 1049 Round and Round We Go 大数模拟

2016-09-21 22:22 316 查看
Round and Round We Go

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12611 Accepted: 5900
Description

A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a"cycle"of the digits of the original number. That is, if you consider the number after the last digit to "wrap around"back to the first digit, the sequence
of digits in both numbers will be the same, though they may start at different positions.For example, the number 142857 is cyclic, as illustrated by the following table: 

142857 *1 = 142857 

142857 *2 = 285714 

142857 *3 = 428571 

142857 *4 = 571428 

142857 *5 = 714285 

142857 *6 = 857142 

Input

Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n.
Thus, "01"is a two-digit number, distinct from "1" which is a one-digit number.)
Output

For each input integer, write a line in the output indicating whether or not it is cyclic.
Sample Input
142857
142856
142858
01
0588235294117647

Sample Output
142857 is cyclic
142856 is not cyclic
142858 is not cyclic
01 is not cyclic
0588235294117647 is cyclic

Source

Greater New York 2001

    题意:给出一个大数,位数为n,将其从一乘到n,若得到的每一个数都可以根据原数本身顺序得到即为cyclic。

    分析: 直接大数模拟即可,具体见代码:

//大数 模拟得结果
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=65;
char s[maxn];
int a[maxn],temp[maxn];
int main()
{
while(~scanf("%s",s))
{
int n=strlen(s);
for(int i=0; i<n; i++)
{
a[i]=s[i]-'0';
temp[i]=a[i];
}
int flag=1;
for(int i=1; i<=n; i++)//i为每次的乘数
{
int f=1;
for(int j=0; j<n; j++)
{
a[j]=temp[j];
a[j]*=i;
}
for(int j=n-1; j>=1; j--)
{
a[j-1]+=a[j]/10;
a[j]%=10;
}
if(a[0]>9) //发生了进位 所得结果位数大于原位数
{
flag=0;
break;
}
f=0;
int ff=0,s=-1;//ff判断是否能够匹配
for(int j=0; j<n; j++)
if(temp[j]==a[0])//需要注意的是 需要对temp中每个和起点相同的点进行匹配
{
s=j;
int fff=1;
for(int k=0; k<n; k++)
{
if(a[k]!=temp[s])
{
fff=0;
break;
}
else
{
s++;
s%=(n);
}

b4a2
}
if(fff)
{
ff=1;//能够有一种排列匹配
break;
}
}
if(s==-1)
f=0;
if(!ff)//不能够匹配
{
flag=0;
break;
}
}
if(flag)
printf("%s is cyclic\n",s);
else
printf("%s is not cyclic\n",s);
}
return 0;
}

//对于其他的数num,如果其位数是n,如果num*(n+1)得到的结果是n个9,那么这个数就是可循环的。    特记下,以备后日回顾。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: