您的位置:首页 > 编程语言 > C语言/C++

1039. Course List for Student (25)

2016-09-17 17:46 274 查看

1039. Course List for Student (25)

时间限制200 ms内存限制65536 kB代码长度限制16000 B判题程序Standard作者CHEN, YueZhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.Input Specification:Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for thecourses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni studentnames are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.Output Specification:For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasingorder. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
本来抱着一线生机想试试看,结果发现这道题还是不能用map,会超时。。。因此只能手写hash函数了。把每个学生上过的课存在一个vector中,最后对vector进行排序即可
#include<iostream>
#include<string>
#include<map>
#include<vector>
#include<algorithm>
#include<iterator>
#include<cstdio>

using namespace std;

vector<int> all[26 * 26 * 26 * 10 + 1];//每个学生一个vector,记录着他上过哪些课

int str2int(char* a){//把每个学生的名字对应到一个唯一的数,即hash的过程
return (a[0] - 'A') * 26 * 26 * 10 + (a[1] - 'A') * 26 * 10 + (a[2] - 'A') * 10 + a[3]-'0';
}

int main(){
int n, k;
int num, count, code;
char name[5];
scanf("%d%d", &n, &k);
for (int i = 0; i < k; i++){
scanf("%d%d", &num, &count);
for (int j = 0; j < count; j++){
scanf("%s", name);
all[str2int(name)].push_back(num);
}
}
for (int i = 0; i < n; i++){
scanf("%s", name);
code = str2int(name);
num = all[code].size();
printf("%s %d", name, num);
sort(all[code].begin(), all[code].end());//上过的课从小到大排序
vector<int>::iterator it = all[code].begin();
while (it != all[code].end()){
printf(" %d", *it);
it++;
}
printf("\n");
}
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 算法 c++