您的位置:首页 > 理论基础 > 计算机网络

hdu5832 CCPC 网络赛 同余求模定理

2016-08-15 09:20 357 查看


A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 362    Accepted Submission(s): 199


Problem Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days
in Xixi a year and 137 days
in Haha a year. 

Now you know the days N after
Big Bang, you need to answer whether it is the first day in a year about the two planets.

 

Input

There are several test cases(about 5 huge
test cases).

For each test, we have a line with an only integer N(0≤N),
the length of N is
up to 10000000.

 

Output

For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

 

Sample Input

10001
0
333

 

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

 

Author

UESTC

 

Source

2016中国大学生程序设计竞赛
- 网络选拔赛

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define maxn 10000010
char a[maxn];
const int mod1=73;
const int mod2=137;

int main()
{
int cnt=1;
//freopen("in.txt","r",stdin);
while(scanf("%s",a)!=EOF)
{
int ans1=0,ans2=0;
int len=strlen(a);
for(int i=0;i<len;i++){
ans1=(ans1*10+(a[i]-'0'))%mod1;
ans2=(ans2*10+(a[i]-'0'))%mod2;
}

if(ans1==ans2&&ans1==0)
printf("Case #%d: YES",cnt++);
else
printf("Case #%d: NO",cnt++);
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: