您的位置:首页 > 编程语言 > C语言/C++

POJ 1416 - Shredding Compan

2016-08-13 21:18 417 查看
Shredding Company

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5381 Accepted: 3023
Description

You have just been put in charge of developing a new shredder(碎纸机) for the Shredding Company Although a "normal" shredder would just
shred sheets of paper into little pieces so that the contents would become unreadable(不值一读的), this new shredder needs to have the
following unusual basic characteristics(特征).

1.The shredder takes as input(输入) a target number and a sheet of paper with a number written on it.

2.It shreds (or cuts) the sheet into pieces each of which has one or more digits(数字) on it.

3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it.

For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder(碎纸机) would cut the sheet
into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations(结合) without
going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination's 43. The combination of 12, 34, and 6 is not valid either, because the
sum 52 (= 12 + 34 + 6) is greater than the target number of 50.



Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50

There are also three special rules :

1.If the target number is the same as the number on the sheet of paper, then the paper is not cut.

For example, if the target number is 100 and the number on the sheet of paper is also 100, then

the paper is not cut.

2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid
combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed.

3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are
two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate(模仿的) the
above characteristics(特征) and rules. Given two numbers, where the first is the target number and the second is the number on the sheet
of paper to be shredded, you need to figure out how the shredder should "cut up" the second number.

Input

The input(投入) consists of several test cases, each on one line, as follows :

tl num1

t2 num2

...

tn numn

0 0

Each test case consists of the following two positive(积极的) integers(整数),
which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded.

Neither integers may have a 0 as the first digit(数字), e.g., 123 is allowed but 0123 is not. You may assume(承担) that
both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input.

Output

For each test case in the input, the corresponding output(输出) takes one of the following three types :

sum part1 part2 ...

rejected

error

In the first type, partj and sum have the following meaning :

1.Each partj is a number on one piece of shredded(切碎的) paper. The order of partj corresponds to the order of the original digits(数字) on
the sheet of paper.

2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +...

Each number should be separated by one space.

The message error is printed if it is not possible to make any combination(结合), and rejected if there is

more than one possible combination.

No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line.

Sample Input
50 12346
376 144139
927438 927438
18 3312
9 3142
25 1299
111 33333
103 862150
6 1104
0 0

Sample Output
43 1 2 34 6
283 144 139
927438 927438
18 3 3 12
error
21 1 2 9 9
rejected
103 86 2 15 0
rejected


Analysis

题目大意:给出一张纸条,上面写着一个不超过6位数的数字,给定一个目标数字,用剪纸机把将纸条剪成若干个小纸条,要求使所有小纸条上的数字加起来不超过目标数字且最接近,先输出所得的数字,再依次输出每个纸条上的数字,如果有多种答案,输出“rejected”,如果答案不存在,输出“error”。

一道DFS的题,每次剪下一段,然后递归,永cut数组存储剪下的位置,如果到递归完成答案符合要求,并且优于上一个符合要求的答案,则将cut数组另存起来,防止下一次递归被修改,v数组存储每个答案出现的次数,如果最后最接近目标数字的答案出现多次,则为“rejected”。

DFS前有一个小小的剪枝,判断每一位数字的和是否大于目标数字,如果大于,直接输出“error”。

Source Code

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char s[10];
int v[1000086], ans, l, n, cut[10], a[10];
void dfs(int sum, int i)
{
if (sum > n)
return;
if (i >= l)
{
v[sum]++;
if (ans < sum)
{
ans = sum;
memcpy(a, cut, sizeof(cut));
}
return;
}
int num = 0;
for (; i < l; i++)
{
num = num * 10 + s[i] - '0';
cut[i + 1] = 1;
dfs(sum + num, i + 1);
cut[i + 1] = 0;
}
}
int main()
{
int sum, i;
while (~scanf("%d %s", &n, s) && (n || strcmp(s, "0")))
{
memset(v, 0, sizeof(v));
memset(cut, 0, sizeof(cut));
sum = ans = 0;
l = (int)strlen(s);
for (i = 0; i < l; i++)
sum += s[i] - '0';
if (sum <= n)
dfs(0, 0);
if (ans)
{
if  (v[ans] > 1)
printf("rejected\n");
else
{
printf("%d ", ans);
for (i = 0; i < l; i++)
{
if (a[i])
printf(" ");
printf("%c", s[i]);
}
printf("\n");
}
}
else
printf("error\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c++ poj dfs 剪枝