您的位置:首页 > 编程语言 > C语言/C++

POJ 3370-Halloween treats(鸽巢原理)

2016-08-05 11:37 302 查看
Halloween treats

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7985 Accepted: 2905 Special Judge
Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts,
the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number
of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.

The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space
separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit
neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets).
If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input
4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output
3 5
2 3 4

Source

Ulm Local 2007

题目意思:

C个小孩去N户人家索要糖果,第i家给出的糖果数为Ai。

孩子们想要能够平分糖果,所以他们选择其中一部分人家索要糖果。

若能够平分,输出孩子们选择的住户编号;若不能,输出"no sweets"。

解题思路:

鸽巢原理。

对于一个正整数序列A1~Am,至少存在整数k,l(l≤k<l≤m),使得Ak~Al之和是m的倍数。

我的思路写的代码不加输入外挂就会超时…限时2000ms,加了之后1902ms险过…Orz

还有阿,这是特判的题…样例给你的只是一种正确情况~

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
using namespace std;
#define maxn 100010
int a[maxn];
struct Remnant
{
int h,r;//记录前h个数和模上c后的余数r
} re[maxn];
bool cmp(const Remnant &x,const Remnant &y)//结构体排序
{
if(x.r==y.r) return (x.h<y.h);
return (x.r<y.r);
}
int getint()//输入外挂
{
char c=getchar();
int t=0;
while (c<'0' || c>'9')
{
c=getchar();
}
while (c>='0' && c<='9')
{
t=t*10+c-'0';
c=getchar();
}
return t;
}

int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
int c,n;
while(cin>>c>>n,c||n)
{
//memset(a,0,sizeof(a));
// memset(re,0,sizeof(Remnant)*maxn);
int flag=-1,h;
long long sum=0;
for(int i=0; i<n; ++i)
{
a[i]=getint();//加了外挂之后1902ms险过…
sum+=a[i];//累加前i个数
re[i].r=sum%c;//保存余数
re[i].h=i+1;//保存前h个数下标h
if(flag==-1&&re[i].r==0) flag=i;//当前存在数的和是c的倍数,即第一次扫描时糖果可分,并记录位置
}
if(flag==-1)//第一次扫描糖果不可分
{
sort (re,re+n,cmp);//所有和的余数递增排序
for(int i=0; i<n-1; ++i)
if(flag==-1&&re[i].r==re[i+1].r)//若两个余数相等,说明它们原来的和是c的倍数
{
flag=re[i].h;//记录开始位置
h=re[i+1].h;//记录结束位置
}
if(flag==-1) puts("no sweets");//糖果不可分
else//第二次扫描发现糖果可分
{
for(int i=flag+1; i<h; ++i)
cout<<i<<" ";
cout<<h<<endl;
}
}
else//第一次扫描时糖果可分
{
for(int i=0; i<flag; ++i)
cout<<i+1<<" ";
cout<<flag+1<<endl;
}
}
return 0;
}

/**
4 5 1 2 3 7 5 3 6 7 11 2 5 13 17 0 0
**/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息