您的位置:首页 > 编程语言 > C语言/C++

stack应用--矩阵乘法次数计算

2016-07-27 21:07 459 查看
[align=left]Problem Description[/align]
Matrix multiplication problem is a typical example of dynamical programming.

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly
depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.

There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

 

[align=left]Input[/align]
Input consists of two parts: a list of matrices and a list of expressions. The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain
one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix. The second part of the input file strictly adheres to the following syntax (given in EBNF): SecondPart = Line { Line } <EOF> Line
= Expression <CR> Expression = Matrix | "(" Expression Expression ")" Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

 

[align=left]Output[/align]
For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number
of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

 

[align=left]Sample Input[/align]

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

 

[align=left]Sample Output[/align]

0
0
0
error
10000
error
3500
15000
40500
47500
15125
思路:这道题,主要应用stack来对表达式的括号进行匹配
#include<iostream>
#include<string>
#include<stack>
using namespace std;
int main()
{
int t;
char c;
int shu[26][2],temp[26][2];
cin >> t;
for (int i = 0; i < t; i++)
{
cin >> c;
cin >> shu[c-'A'][0] >> shu[c - 'A'][1];
}
string s;
stack<char> exp;
while (cin >> s)
{
for (int i = 0; i < 26; i++)
{
temp[i][0] = shu[i][0];
temp[i][1] = shu[i][1];
}
int ans = 0;
if (s.size() == 1)
cout << 0 << endl;
else
{
int i;
for ( i = 0;i<s.size();i++)
{
if (s[i] != ')')exp.push(s[i]);
else
{
char b = exp.top(); exp.pop();
char a = exp.top(); exp.pop(); exp.pop();
int a1 = a - 'A';
int b1 = b - 'A';
if (temp[a1][1] != temp[b1][0]) {
cout << "error" << endl;
break;
}
else
{
ans += temp[a1][0] * temp[a1][1] * temp[b1][1];
temp[a1][1] = temp[b1][1];//相乘后结果入栈
exp.push(a);
}
}
}
if(i==s.size())
cout << ans << endl;
while (!exp.empty())
exp.pop();
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  stack应用 c++