您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表七:单链表中重复元素的删除 sdutoj2122

2016-07-27 11:02 381 查看



数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS Memory limit: 65536K

题目描述

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

输入

第一行输入元素个数n;

第二行输入n个整数。

输出

第一行输出初始链表元素个数;

第二行输出按照逆位序所建立的初始链表;

第三行输出删除重复元素后的单链表元素个数;

第四行输出删除重复元素后的单链表。

示例输入

10
21 30 14 55 32 63 11 30 55 30


示例输出

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21


///注意格式控制,删除后节点的移动

#include <iostream>
#include <stdlib.h>
using namespace std;

struct f
{
int data;
struct f *next;
}*a,*p,*tail,*head;

int main()
{
int n,i;
cin>>n;
head=new f;
p=new f;
cin>>p->data;
p->next=NULL;
tail=p;
for (i=2; i<=n; i++)
{
p=new f;
cin>>p->data;
head->next=p;
p->next=tail;
tail=p;
}///逆序建立链表

cout<<n<<endl;
tail=head->next;
while (tail)
{
cout<<tail->data;
if (tail->next!=NULL)
{
cout<<" ";
}
tail=tail->next;
}

a=head->next;
while (a)/// 从第一个开始 从其下一个判断是否重复
{
tail=a;
p=a->next;
while (p)
{
if (a->data == p->data)
{
tail->next=p->next;///delete p
n--;
}
else
{
tail=tail->next;///注意节点的移动
}
p=p->next;
}
a=a->next;
}

cout<<endl<<n<<endl;

tail=head->next;
while (tail)
{
cout<<tail->data;
if (tail->next!=NULL)
{
cout<<" ";
}
tail=tail->next;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息