您的位置:首页 > 编程语言 > Go语言

hdu 5190 Go to movies(水)

2016-07-24 16:18 603 查看


Go to movies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1028    Accepted Submission(s): 542


Problem Description

Winter holiday is coming!As the monitor, LeLe plans to go to the movies.

Because the winter holiday tickets are pretty expensive, LeLe decideds to try group-buying.

 

Input

There are multiple test cases, about 20 cases.
The first line of input contains two integers n,m(1≤n,m≤100). n indicates
the number of the students. mindicates
how many cinemas have offered group-buying.

For the m lines,each
line contains two integers ai,bi(1≤ai,bi≤100),
indicating the choices of the group buying cinemas offered which means you can use biyuan
to buy ai tickets
in this cinema.

 

Output

For each case, please help LeLe **choose a cinema** which costs the least money. Output the total money LeLe should pay.

 

Sample Input

3 2
2 2
3 5

 

Sample Output

4

HintLeLe can buy four tickets with four yuan in cinema 1.

题意:给你n个学生和m个电影院,每个电影院可以用b元买a张票

问你哪个电影院可以话最少元买到n个学生的票,输出价钱

思路:水题,直接模拟

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define INF 999999999
int main()
{
int n,m;
int a,b;
while(~scanf("%d %d",&n,&m))
{
int ans=INF;
for(int i=1;i<=m;i++)
{
scanf("%d %d",&a,&b);
int cost=n/a;
if(n%a!=0) cost++;
ans=min(ans,cost*b);
}
printf("%d\n",ans);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: