您的位置:首页 > 编程语言 > Go语言

NYOJ 30 Gone Fishing

2016-07-22 20:55 459 查看


Gone Fishing

时间限制:3000 ms  |  内存限制:65535 KB
难度:5

描述John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish
at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 <
ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes,
denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal
to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch. 

Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5. 

输入You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a
line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0. 

输出For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line
even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. 

If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line
between cases. 

样例输入
2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0


样例输出
45, 5
Number of fish expected: 31

240, 0, 0, 0
Number of fish expected: 480

115, 10, 50, 35
Number of fish expected: 724


         题意:John有h个小时的钓鱼时间,一共有n个湖泊,它们在一条直线上。从第1个湖开始,可以在任意一个湖停下,每到达一个湖,这个湖开始有f[i]条鱼,钓一次鱼需要5分钟,5分钟后这个湖的鱼的数量为上次数量减去d[i],并且从第i个湖到第i+1个湖需要ti*5的时间。如果某个时间段期望钓到的鱼数小于或者等于di,那么下一个时间段湖中将不再有鱼剩下。为了简化计划,John假设没有其他钓鱼人影响到他的钓鱼数目。目标是让他能钓到的鱼最多。在每个湖他所花的时间必须是5分钟的倍数。



      分析:为了叙述方便,把钓5分钟鱼称为钓一次鱼。首先枚举John需要走过的湖泊数X,也就是假设他从湖泊1走到湖泊X,在湖泊X停止钓鱼,则路上花去的时间记为time[X]。在这个前提下,可以认为John能从一个湖“瞬间转移”到另一个湖,那么在任意一个时刻都可以从湖泊1到湖泊X中任选一个湖泊来钓鱼。因此,采取贪心策略,每次选一个鱼最多的湖泊来钓鱼。对于每个湖泊而言,由于在任何时候鱼的数量之和John在该湖钓鱼的次数有关,而和钓鱼的总次数无关,所以这个策略是最优的。假设一共允许钓k次鱼,那么每次在n个湖泊中选择鱼最多的一个湖泊钓,选择每次钓鱼地点的时间复杂度为O(n),总的时间复杂度为O(kn^2)。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[30],d[30],time[30],ff[30],tmp[30],ans[30];
int main()
{
int i,j,n,h,t,cas=0;
while(scanf("%d",&n)&&n)
{
scanf("%d",&h);
h*=60;
for(i=0; i<n; i++)
scanf("%d",&f[i]);
for(i=0; i<n; i++)
scanf("%d",&d[i]);
time[0]=0;
for(i=1; i<n; i++)
{
scanf("%d",&t);
time[i]=time[i-1]+5*t;
}
memset(ans,0,sizeof(ans));
int maxsum=-1;
for(i=0; i<n; i++)
{
int sum=0,left_time=h-time[i];
for(j=0; j<=i; j++)
ff[j]=f[j];
memset(tmp,0,sizeof(tmp));
while(left_time>0)
{
int max=0,mark=0;
for(j=0; j<=i; j++)
{
if(ff[j]>max)
{
max=ff[j];
mark=j;
}
}
if(max==0) break;
sum+=max;
tmp[mark]+=5;
ff[mark]-=d[mark];
left_time-=5;
}
if(left_time>0)
tmp[0]+=left_time;
if(sum>maxsum)
{
maxsum=sum;
for(j=0; j<=i; j++)
ans[j]=tmp[j];

}
}
if(cas>0)
printf("\n");
printf("%d",ans[0]);
for(i=1; i<n; i++)
printf(", %d",ans[i]);
printf("\nNumber of fish expected: %d\n",maxsum);
cas++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: