您的位置:首页 > 数据库 > Oracle

HDU 5718 Oracle

2016-07-18 19:16 417 查看
Problem Description

There is once a king and queen, rulers of an unnamed city, who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche, whose admirers, neglecting the proper worship of the love goddess Venus, instead pray and make offerings to her. Her father, the king, is desperate to know about her destiny, so he comes to the Delphi Temple to ask
for an oracle.

The oracle is an integer n without
leading zeroes. 

To get the meaning, he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>, and their sum should be as large as possible. 

Help him to work out the maximum sum. It might be impossible to do that. If so, print `Uncertain`.

 

Input

The first line of the input contains an integer T (1≤T≤10),
which denotes the number of test cases.

For each test case, the single line contains an integer n (1≤n<1010000000).

 

Output

For each test case, print a positive integer or a string `Uncertain`.

 

Sample Input

3
112
233
1

 

Sample Output

22
35
Uncertain

Hint
In the first example, it is optimal to split $ 112 $ into $ 21 $ and $ 1 $, and their sum is $ 21 + 1 = 22 $.

In the second example, it is optimal to split $ 233 $ into $ 2 $ and $ 33 $, and their sum is $ 2 + 33 = 35 $.

In the third example, it is impossible to split single digit $ 1 $ into two parts.
简单题,先判断是否有两个非零数,然后就是取一个最小的出来加进去
#include<set>
#include<map>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
using namespace std;
const int low(int x) { return x&-x; }
const int N = 1e7 + 10;
const int INF = 0x7FFFFFFF;
int T, n, m, f[10], a
;
char s;

int main()
{
scanf("%d", &T); getchar();
while (T--)
{
//scanf("%d%d", &n, &m);
memset(f, 0, sizeof(f));
while ((s = getchar()) <= '9' && s >= '0') f[s - '0']++;
int sum = 0;
rep(i, 1, 9) sum += f[i];
if (sum < 2) printf("Uncertain\n");
else
{
int t = 0, k = 0;
rep(i, 1, 9) if (f[i]) { f[i]--; k = i; break; }
rep(i, 0, 9) while (f[i]--) a[t++] = i;
rep(i, 0, t - 1)
{
int kk = a[i];
a[i] = (a[i] + k) % 10;
k = (k + kk) / 10;
}
if (k) a[t++] = k;
while (t--) printf("%d", a[t]);
putchar(10);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU