您的位置:首页 > 编程语言 > C语言/C++

POJ 3461 Oulipo [KMP模板题]

2016-07-17 22:43 288 查看
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program
that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T,
count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

Source

BAPC 2006 Qualification
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

KMP~

标准模板(?)~

#include<cstdio>
#include<cstring>

int n,next[1000000],len1,len2;
char a[10000],s[1000000];

void getnext(char *u,int len)
{
int k=0;
next[1]=0;
for(int i=2;i<=len;i++)
{
while(k>0 && u[k+1]!=u[i]) k=next[k];
if(u[k+1]==u[i]) k++;
next[i]=k;
}
}

int KMP(char *u,char *v)
{
int ans=0;
getnext(u,len1);
int k=0;
for(int i=1;i<=len2;i++)
{
while(k>0 && u[k+1]!=v[i]) k=next[k];
if(u[k+1]==v[i]) k++;
if(k==len1)
{
ans++;k=next[k];
}
}
return ans;
}

int main()
{
scanf("%d",&n);
while(n--)
{
memset(next,0,sizeof(next));
scanf("%s",a+1);
scanf("%s",s+1);
len1=strlen(a+1),len2=strlen(s+1);
printf("%d\n",KMP(a,s));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ KMP