您的位置:首页 > 编程语言 > C语言/C++

1046. Shortest Distance (20)

2016-07-10 19:46 591 查看

1046. Shortest Distance (20)

 

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ...
DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers
in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the
total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:
3
10
7


 

#include <stdio.h>
#include <math.h>
int main()
{
int N,i,temp,p1,p2;
int a[100010]={0},sum;
scanf("%d",&N);
for(i=2;i<N+1;i++)  //a[i]存储从1到达i节点的成本
{
scanf("%d",&temp);
a[i] =  a[i-1]+temp;
}
scanf("%d",&temp);
sum = a[--i] +temp;   //sum存储整个cycle的长
scanf("%d",&N);
for(i=0;i<N;i++)
{
scanf("%d%d",&p1,&p2);
temp = abs(a[p2] - a[p1]);
if( temp >= sum-temp)
{
printf("%d\n",sum-temp);
}
else
{
printf("%d\n",temp);
}
}
return 0;
}


 

 

 

 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息