您的位置:首页 > 编程语言 > Java开发

HDU 1236 排名 Java实现

2016-06-30 20:09 295 查看


排名

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20727    Accepted Submission(s): 7689


Problem Description

今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑 

每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的 

考生,并将他们的成绩按降序打印。 

 

Input

测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N 

< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一 

名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号 

(题目号由1到M)。 

当读入的考生人数为0时,输入结束,该场考试不予处理。 

 

Output

对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高 

到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考 

号的升序输出。 

 

Sample Input

4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0

 

Sample Output

3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

Hint
Huge input, scanf is recommended.

 

Source

浙大计算机研究生复试上机考试-2005年

import java.awt.List;
import java.util.ArrayList;
import java.util.Arrays;
import java.util.Collections;
import java.util.Comparator;
import java.util.Iterator;
import java.util.LinkedList;
import java.util.Scanner;

public class Main {

/**
* @param args
*/
public static class Student {
String num;
int n = 0;
int score = 0;
}

public static class ComparatorStudent implements Comparator{

@Override
public int compare(Object arg0, Object arg1) {
// TODO Auto-generated method stub
Student student1=(Student)arg0;
Student student2 = (Student)arg1;
int flag;
if(student1.score>student2.score){
flag=-1;
}else if(student1.score==student2.score){
flag =0;
}else{
flag=1;
}
if(flag==0){
return student1.num.compareTo(student2.num);
}else{
return flag;
}
}

}
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner in = new Scanner(System.in);
while (true) {
int N = in.nextInt();
if (N == 0) {
break;
}
int M = in.nextInt();
int avg = in.nextInt();
int[] eves = new int[M];
for (int i = 0;i<M;i++){
eves[i] = in.nextInt();
}
ArrayList<Student> L = new ArrayList<Student>();
while(N!=0){
N--;
Student stu = new Student();
stu.num = in.next();
stu.n = in.nextInt();
for (int i = 0;i<stu.n;i++){
int a =in.nextInt();
stu.score += eves[a-1];
}
L.add(stu);
}
int peo=0;
ComparatorStudent comparator = new ComparatorStudent();
Collections.sort(L,comparator);
for (Student student : L) {
if(student.score>=avg){
peo++;
}
}
System.out.println(peo);
for (Student student : L) {
if(student.score>=avg){
System.out.println(student.num+" "+student.score);
}
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 java ACM