您的位置:首页 > 编程语言 > C语言/C++

1104. Sum of Number Segments (20)

2016-06-05 11:58 537 查看
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3,
0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than
1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.
Sample Input:
4
0.1 0.2 0.3 0.4

Sample Output:
5.00

num 输入队列有多少个数
依次输入num个in,都是不大于1.0的小数,
要求输出这个队列非空子串的和,保留两位小数,有没有换行符结束都可以通过。
注意:如果 sum += (num - i + 1)*i*in;就有两个错误,详见后面。double型in要在前面,可能是数据大溢出了吧
串的各部分术语http://xujiayu317.blog.163.com/blog/static/25475209201601895222262/
评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
6月05日 11:43答案正确201104C++
(g++ 4.7.2)
119628datrilla


测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确351212/12
1答案正确45123/3
2答案正确1196043/3
3答案正确636282/2
#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
double sum=0, in;
int num;
cin >> num;
for (int i = num; i > 0; i--)
{
cin >> in;
sum += in*(num - i + 1)*i;
}
cout << setiosflags(ios::fixed) << setprecision(2)
<< sum ;
system("pause");
return 0;
}


评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
6月05日 11:42部分正确151104C++
(g++ 4.7.2)
96624datrilla


测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确351212/12
1答案正确35123/3
2答案错误925120/3
3答案错误966240/2
#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
double sum=0, in;
int num;
cin >> num;
for (int i = num; i > 0; i--)
{
cin >> in;
sum += (num - i+1)*i*in;
}
cout << setiosflags(ios::fixed) << setprecision(2)
<< sum ;
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++