您的位置:首页 > 理论基础 > 数据结构算法

数据结构上机测试2-1:单链表操作A

2016-05-28 19:12 363 查看

题目描述

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。

输入

第一行输入数据个数n;

第二行依次输入n个整数;

第三行输入欲删除数据m。

输出

第一行输出原始单链表的长度;

第二行依次输出原始单链表的数据;

第三行输出完成删除后的单链表长度;

第四行依次输出完成删除后的单链表数据。

示例输入

10
56 25 12 33 66 54 7 12 33 12
12


示例输出

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33




#include <bits/stdc++.h>

using namespace std;

struct node

{

int data;

struct node *next;

};

int main()

{

int i,n,m,w=0,l=0;

struct node *head,*p,*q,*tail;

head = new struct node();

head -> next = NULL;

cin>>n;

tail=head;

for(i=0; i<n; i++)

{

q=new struct node();

cin>>q->data;

q->next=NULL;

tail->next=q;

tail=q;

}

cin>>m;

cout<<n<<endl;

p=head->next;

while(p!=NULL)

{

cout<<p->data;

if(p->next!=NULL)

cout<<" ";

p=p->next;

}

cout<<endl;

p=head->next;

while(p!=NULL)

{

if(p->data==m)

{

w++;

p=p->next;

}

else

p=p->next;

}

cout<<n-w<<endl;

p=head->next;

while(p!=NULL)

{

if(p->data==m)

p=p->next;

else

{

cout<<p->data;

l++;

if(l!=(n-w))

cout<<" ";

p=p->next;

}

}

cout<<endl;

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: