您的位置:首页 > 理论基础 > 数据结构算法

HDU1022 acm 数据结构 Train Problem I

2016-05-25 15:24 337 查看
[align=left]Problem Description[/align]
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes
a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves,
train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your
task is to determine whether the trains can get out in an order O2.







 

[align=left]Input[/align]
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file.
More details in the Sample Input.

 

[align=left]Output[/align]
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out"
for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

 

[align=left]Sample Input[/align]

3 123 321
3 123 312

 

[align=left]Sample Output[/align]

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".

 

[align=left]火车进站问题,注意火车可以先走,不需要所有的火车都进后再走。[/align]
[align=left]
[/align]

#include <stdio.h>

#include <stack>

using namespace std;

int main()

{
int n,i,j,num;
char in[10],out[10];
int flag[20];
while(scanf("%d",&n)!=EOF)
{
stack<char> s;
i=j=num=0;
scanf("%s",in);
scanf("%s",out);
while(j<n)
{
if(s.empty() || s.top()!=out[j] && i<n)
{
s.push(in[i]);
flag[num++]=1;
i++;
}
else
{
if(s.top()==out[j])
{
s.pop();
flag[num++]=0;
j++;
}
else
break;
}
}
if(s.empty())
{
printf("Yes.\n");
for(i=0;i<num;i++)
{
if(flag[i]==1)
printf("in\n");
else
printf("out\n");
}
printf("FINISH\n");
}
else
printf("No.\nFINISH\n");
}
return 0;

}

[align=left]
[/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: