您的位置:首页 > 编程语言 > Go语言

[POJ2262]Goldbach's Conjecture

2016-05-15 19:08 543 查看
Goldbach's Conjecture

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 42683 Accepted: 16340
Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 

written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 

20 = 3 + 17 = 7 + 13. 

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 

Each test case consists of one even integer n with 6 <= n < 1000000. 

Input will be terminated by a value of 0 for n.
Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair
where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."
Sample Input
8
20
42
0

Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source

Ulm Local 1998

题目地址:http://poj.org/problem?id=2262

题解:问一个数可不可以由两个奇素数的和组成 找出其中奇素数差值最大的一组 

简单模拟就好了 直接奇素数打表 然后在表中直接找就好了

AC代码:

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100000;
int prime[maxn]; //奇数素数
bool flag;
int mark;
int ans;
void is_prime(); //奇数素数打表
bool find_prime(int m); //在奇数素数打表里寻找有没有这个数

int main() {
is_prime();
int n;
while(~scanf("%d", &n) && n) {
flag = false;
for(int i = 0; i < mark; ++i) {
if(find_prime(n - prime[i])) { //如果两个是都是奇素数 则标记flag 并把第一个奇素数赋给ans
flag = true;
ans = prime[i];
break;
}
}

if(flag) {
printf("%d = %d + %d\n", n, ans, n - ans);
}
else {
puts("Goldbach's conjecture is wrong.");
}
}
return 0;
}

void is_prime() {
prime[0] = 3;
mark = 1;
for(int i = 5; i <= 1000000; i+=2) {
flag = true;
for(int j = 3; j * j <= i; j += 2) {
if(i % j == 0) {
flag = false;
break;
}
}
if(flag) {
prime[mark++] = i;
}
}
}

bool find_prime(int m){
return binary_search(prime, prime + mark, m); //这里用了STL中的二分查找 节约时间
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: