您的位置:首页 > 移动开发 > IOS开发

HDU 1017 A Mathematical Curiosity【水题】

2016-05-14 10:40 537 查看

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 36048 Accepted Submission(s): 11498



[align=left]Problem Description[/align]
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

[align=left]Input[/align]
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

[align=left]Output[/align]
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

[align=left]Sample Input[/align]

1

10 1
20 3
30 4
0 0


[align=left]Sample Output[/align]

Case 1: 2
Case 2: 4
Case 3: 5


题意翻译:
满足 0<a<b<n
并且满足 (a^2+b^2+m)/a*b 为整数 符合条件的 点(a,b)的个数

格式:
输入N组数
每组以0 0 结尾
0 0 结尾后空一行
第N组结尾不空行





#include<stdio.h>
int main (void)
{
int a,b,k=1,N,n,m;
scanf("%d",&N);
while(N--)
{
k=1;
while(~scanf("%d%d",&n,&m),n+m)
{
int sum=0;
for(int i=1; i<n; i++)
{
for(int j=i+1; j<n; j++)
{
if((i*i+j*j+m)%(i*j)==0)
{
sum++;
}
}
}
printf("Case %d: %d\n",k++,sum);
}
if(N)
printf("\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: